比如: 现有7个车厢,每个乘客数依次为 35, 40, 50, 10, 30, 45, and 60. 每个迷你车头最多能拉动2节车厢,则 如下选择:1-2, 3-4, and 6-7, they can transport 240 passengers
已知每节车厢的乘客数目、每节迷你车头能拉动的车厢数目。求最多能运载的乘客数
输入: 第一行 a single integer t (1 <= t <= 11)……( the number of test cases, followed by the input data for each test case.) 每一对case: 第一行:n 车厢数(will not exceed 50,000.) 第二行 :n个数字,代表从车头开始每节车厢的人数( No coach holds more than 100 passengers.) 第三行:cn ,迷你车厢能装载的最多乘客数目(This number will not exceed 1/3 of the number of passenger coaches.) 输出: 对each case:the maximum number of passengers which can be transported by the three mini locomotives.
Description
A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:
1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.
For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.
If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.
Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives.
Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i
th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.
Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
Sample Input
1
7
35 40 50 10 30 45 60
2
Sample Output
240
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[5][155000];
int main()
{
int Case;
int sum[6200];
scanf("%d",&Case);
for(int t=0;t<Case;t++)
{
int n,m;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
int a;
sum[0]=0;
scanf("%d",&a);
sum[i]=sum[i-1]+a;
}
scanf("%d",&m);
for(int i=1;i<=3;i++)
{
for(int j=m;j<=n;j++)
dp[i][j]=max(dp[i][j-1],dp[i-1][j-m]+sum[j]-sum[j-m]);
}
printf("%d\n",dp[3][n]);
}
return 0;
}