hdu 1524 A Chess Game 博弈论

题意:

两个人在一个有向五环图上面走棋子,每次只能走一步,最后谁

* 没有棋子可走就败,然后棋子可以重叠,并且有n个棋子。要求判断

* 先手的胜负。

纠结了好长时间一直在想为什么sg函数要呢么定义然后看了各种博客但是只是讲了,定义的内容却很少有讲为什么的。。。。

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification! 
 

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case. 
 

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed. 
 

Sample Input

       
       
4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0
 

Sample Output

       
       
WIN WIN WIN LOSE WIN
 

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int Map[1005][1005];
int sg[1005],n;
int dfs(int a)
{
    if(sg[a]!=-1)
        return sg[a];
    bool vis[2000]={0};
    for(int i=0;i<n;i++)
    {
        if(Map[a][i]==1)
        {
            vis[dfs(i)]=1;
        }
    }
    for(int i=0;i<n;i++)
        if(vis[i]==0)
        return sg[a]=i;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(sg,-1,sizeof(sg));
        memset(Map,0,sizeof(Map));
        for(int i=0; i<n; i++)
        {
            int a;
            scanf("%d",&a);
            if(a==0) //注意这个地方,这个地方是当没有后继的时候他的sg函数为0
            {
                sg[i]=0;
                continue;
            }
            while(a--)
            {
                int b;
                scanf("%d",&b);
                Map[i][b]=1;
            }
        }
        int m;
        while(~scanf("%d",&m)&&m)
        {
            int ans=0;
            for(int i=0;i<m;i++)
            {
                int a;
                scanf("%d",&a);
                if(sg[a]!=-1)
                    ans^=sg[a];
                else
                    ans^=dfs(a);
            }
            if(ans==0)
                printf("LOSE\n");
            else
                printf("WIN\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值