回形取数

package org.bluebridge.lx;

/*
 *回形取数  

 问题描述
 回形取数就是沿矩阵的边取数,若当前方向上无数可取或已经取过,则左转90度。一开始位于矩阵左上角,方向向下。
 输入格式
 输入第一行是两个不超过200的正整数m, n,表示矩阵的行和列。接下来m行每行n个整数,表示这个矩阵。
 输出格式
 输出只有一行,共mn个数,为输入矩阵回形取数得到的结果。数之间用一个空格分隔,行末不要有多余的空格。
 样例输入
 3 3
 1 2 3
 4 5 6
 7 8 9
 样例输出
 1 4 7 8 9 6 3 2 5
 样例输入
 3 2
 1 2
 3 4
 5 6
 样例输出
 1 3 5 6 4 2 */

import java.util.Scanner;

public class BASIC_25 {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);

		int n = sc.nextInt(), m = sc.nextInt();

		int[][] arr = new int[n][m];

		for (int i = 0; i < n; i++)
			for (int j = 0; j < m; j++)
				arr[i][j] = sc.nextInt();
		sc.close();

		int count = n * m, x = 0, y = 0, minx = 0, miny = 0;
		while (count > 0) {

			// 打印左边
			while (x < n && count > 0) {
				System.out.print(arr[x++][y] + " ");
				count--;
			}
			x--;
			y++;
			n--;

			// 打印下边
			while (y < m && count > 0) {
				System.out.print(arr[x][y++] + " ");
				count--;
			}
			x--;
			y--;
			m--;

			// 打印右边
			while (x >= minx && count > 0) {
				System.out.print(arr[x--][y] + " ");
				count--;
			}
			x++;
			y--;
			minx++;

			// 打印上边
			while (y > miny && count > 0) {
				System.out.print(arr[x][y--] + " ");
				count--;
			}
			x++;
			y++;
			miny++;
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值