hdu 5319 2015多校对抗赛三

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 941    Accepted Submission(s): 427


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

Output
Output an integer as described in the problem description.
 

Sample Input
  
  
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

Sample Output
  
  
3 6
 

Author
ZSTU
 

Source
 

坑题意的水题:

R类线只能\  B类线只能/

然后暴力就行了

#include<iostream>
#include<cstdio>
#include<cstring>
char a[]={'R','B'};
int d[2][2] = {1,1,1,-1};
char s[100][100];
int n,m;
bool flag[100][100];
bool could(int x,int y,int t)
{
    if(x<0||y<0||x>=n||y>=m)
        return false;
    if(s[x][y] != a[t] && s[x][y]!='G') return false;
    return true;
}
void solve(int i,int j,int t)
{
    while(could(i,j,t))
    {flag[i][j] = false;i+=d[t][0];j+=d[t][1];}
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i = 0;i<n;i++) scanf("%s",s[i]);
        m = strlen(s[0]);
        memset(flag,true,sizeof flag);
        int ans = 0;
        for(int i = 0;i<n;i++)
            for(int j = 0;j<m;j++)
                if((s[i][j]=='R'||s[i][j]=='G') && flag[i][j])
                {
                    solve(i,j,0);
                    ans++;
                }
        memset(flag,true,sizeof flag);
        for(int i = 0;i<n;i++)
            for(int j = 0;j<m;j++)
                if((s[i][j]=='B'||s[i][j]=='G') && flag[i][j])
                {
                    solve(i,j,1);
                    ans++;
                }
        printf("%d\n",ans);
    }
}
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n,m;
char mapt[60][60];
char str[60];
int dir[2][2]={{1,1},{1,-1}};
bool judge(int x,int y){
    if(1<=x&&x<=n&&1<=y&&y<=m)return true;
    return false;
}
int doit(int x,int y,int i){
    int res=0;
    while(judge(x,y)){
        int cnt=0;
        while(judge(x,y)){
            if(i==0){
                if(mapt[x][y]=='.'||mapt[x][y]=='B')break;
                if(mapt[x][y]=='G'){
                    cnt=1;
                    mapt[x][y]='B';
                }
                if(mapt[x][y]=='R'){
                    cnt=1;
                    mapt[x][y]='.';
                }
            }
            else {
                if(mapt[x][y]=='.')break;
                if(mapt[x][y]=='B'){
                    mapt[x][y]='.';
                    cnt=1;
                }
            }
            x+=dir[i][0],y+=dir[i][1];
        }
        res+=cnt;
        if(i==0)while(judge(x,y)&&(mapt[x][y]=='.'||mapt[x][y]=='B'))x+=dir[i][0],y+=dir[i][1];
        else while(judge(x,y)&&mapt[x][y]=='.')x+=dir[i][0],y+=dir[i][1];
    }
//    cout<<res<<endl;
    return res;
}
void out(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=m;j++)
            cout<<mapt[i][j];
        cout<<endl;
    }
    cout<<endl;
}
int main(){
    int T;scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%s",str);
            m=strlen(str);
            for(int j=1;j<=m;j++)
                mapt[i][j]=str[j-1];
        }
//        out();
        int ans=0;
        for(int i=1,j=1;i<=n;i++)
            ans+=doit(i,j,0);
//        out();
        for(int i=1,j=2;j<=m;j++)
            ans+=doit(i,j,0);
//        out();
        for(int i=1,j=1;j<=m;j++)
            ans+=doit(i,j,1);
//        out();
        for(int i=2,j=m;i<=n;i++)
            ans+=doit(i,j,1);
//        out();
        printf("%d\n",ans);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值