Hdu 5323 2015多校对抗赛三

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2029    Accepted Submission(s): 617


Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values:  Lu  and  Ru .
- If  Lu=Ru , u is a leaf node. 
- If  LuRu , u has two children x and y,with  Lx=Lu , Rx=Lu+Ru2 , Ly=Lu+Ru2+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.



Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value  Lroot=0  and  Rroot=n contains a node u with  Lu=L  and  Ru=R .
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LRL+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
  
  
6 7 10 13 10 11
 

Sample Output
  
  
7 -1 12
 

Author
ZSTU
 

给定一个区间 [l,r] ,求一个最小的线段树存在此区间节点,输出最小线段树大小即可。

暴力搜索,对于一个区间节点,他的父亲节点可能存在四种状态:

(l,2*r-l);
(l,2*r-l+1);
(2*l-1-r,r);
(2*l-2-r,r);

剪枝有:答案剪枝,区间可行性剪枝(线段树右节点长度不能大于左节点长度)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
#define LL long long
#define inf 1000000000000ll
LL ans;
void dfs(LL l,LL r)
{
    if(ans<=r)return;
    if(l==0) {if(ans>r)ans=r;return;}
    if(r-l+1>l) return;
    dfs(2*l-1-r,r);
    dfs(2*l-2-r,r);
    dfs(l,2*r-l);
    dfs(l,2*r-l+1);
}
int main()
{
    LL l,r;
    while(~scanf("%lld%lld",&l,&r))
    {
        ans = inf;
        dfs(l,r);
        if(ans == inf) puts("-1");else printf("%lld\n",ans);
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值