2015ACM多校对抗赛第四场 hdu 5327

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=5327

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 442    Accepted Submission(s): 319


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval  [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer  T (T1000) , indicating the number of testcases. 

For each test case, there are two numbers  a  and  b , as described in the statement. It is guaranteed that  1ab100000 .
 

Output
For each testcase, print one line indicating the answer. 
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

Author
XJZX
 

Source
 

题意:问区间有多少漂亮数。漂亮数定义为数字没有重复出现的数。
用前缀和做就OK了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int sum[100001];
int judge(int x){
    int ha[10];
    memset(ha,0,sizeof ha);
    while(x){
        ha[x%10]++;
        if(ha[x%10]>1)return 0;
        x/=10;
    }
    return 1;
}
void init(){
    sum[0]=0;
    for(int i=1;i<=100000;i++){
        int ok=judge(i);
        sum[i]+=sum[i-1]+ok;
    }
}
int main(){
    init();
    int T;scanf("%d",&T);
    while(T--){
        int a,b;
        scanf("%d%d",&a,&b);
        printf("%d\n",sum[b]-sum[a-1]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值