【POJ1679】【次小生成树】【替换边】

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24427 Accepted: 8691

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source



#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int T,n,m;
int cost[110][110];
int d[110];
bool in[110];
bool used[110][110];
int maxe[110][110];
int pre[110];
int prim()
{
	int mst = 0;
	for(int i=0;i<=n;i++) 
	{
		d[i] = 0x3f3f3f3f;
		in[i] = false;
		pre[i] = i;
		for(int j=1;j<=n;j++) 
		{
			used[i][j] = false;
			maxe[i][j] = 0;
		}
	}
	d[1] = 0;
	for(int i=0;i<n;i++)
	{
		int mins = 0x3f3f3f3f;
		int p = -1;
		for(int j=1;j<=n;j++)
		{
			if(!in[j] && d[j] < mins)
			{
				mins = d[j];
				p = j;
			}
		}
		if(p == -1) return -1;
		in[p] = true;
		used[pre[p]][p] = true;
		mst += d[p];
		for(int j=1;j<=n;j++)
		{
			if(j == p) continue;
			if(in[j])
			{
				maxe[j][p] = max(d[p],maxe[pre[p]][j]);
			}
			else
			{
				if(d[j] > cost[j][p])
				{
					d[j] = cost[j][p];
					pre[j] = p;
				}
			}
		}
	}
	return mst;
}

int smst(int mst)
{
	int ret = 0x3f3f3f3f;
	for(int i=1;i<=n;i++)
	{
		for(int j=i+1;j<=n;j++)
		{
			if(!used[i][j])
			{
				ret = min(ret,mst-maxe[i][j]+cost[i][j]);
			}
		}
	}
	if(ret == 0x3f3f3f3f) return -1;
	return ret;
}
int main()
{
    scanf("%d",&T);
	while(T --)
	{
		scanf("%d%d",&n,&m);
		memset(cost,0x3f3f3f3f,sizeof(cost));
		for(int i=1;i<=n;i++) cost[i][i] = 0;
		for(int i=0;i<m;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			cost[u][v] = cost[v][u] = w;
		}
		int r1 = prim();
		int r2  = smst(r1);
		if(r1 == -1 || r1 == r2) printf("Not Unique!\n");
		else printf("%d\n",r1);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值