EOJ1424

Hard to Believe, but True!

Time Limit:1000MS Memory Limit:30000KB
Total Submit:446 Accepted:154

Description 

The fight goes on, whether to store numbers starting with their most significant digit or their least significant digit. Sometimes this is also called the "Endian War". The battleground dates far back into the early days of computer science. Joe Stoy, in his (by the way excellent) book "Denotational Semantics", tells following story:

"The decision which way round the digits run is, of course, mathematically trivial. Indeed, one early British computer had numbers running from right to left (because the spot on an oscilloscope tube runs from left to right, but in serial logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by accident, he would slip into this mode even for decimal arithmetic, and write things like 73+42=16. The next version of the machine was made more conventional simply by crossing the x-deflection wires: this, however, worried the engineers, whose waveforms were all backwards. That problem was in turn solved by providing a little window so that the engineers (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.
[C. Strachey - private communication.]" 


You will play the role of the audience and judge on the truth value of Turing's equations.

Input 

The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c", where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.

Output 

For each test case generate a line containing the word "True" or the word "False", if the equation is true or false, respectively, in Turing's interpretation, i.e. the numbers being read backwards.

Sample Input 

73+42=16
5+8=13
10+20=30
0001000+000200=00030
1234+5=1239
1+0=0
7000+8000=51
0+0=0

Sample Output 

True
False
True
True
False
False
True
True



大致题意为,将等号左边的数据倒置,相加。看是否等于输出的数据的倒置


#include <stdio.h>
#include <string.h>

int transpose(char *N){
    int M = 0, i = strlen(N) - 1;
    while(i != -1)
        M = M * 10 + N[i--] - '0';
    return M;
}



int main(){
    char adden1[8] = {0}, adden2[8] = {0}, sum[9] = {0};

    while(1){
        scanf("%[0-9]+%[0-9]=%s", adden1, adden2, sum);
        getchar();
        if(!transpose(adden1) && !transpose(adden2) && !transpose(sum))
            break;

        if(transpose(adden1) + transpose(adden2) == transpose(sum))
            printf("True\n");
        else
            printf("False\n");

    }
    printf("True\n");   //为最终的0+0=0做出输出
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值