java ee

用了两天时间解决这个错误,一开始借的书是myeclipse,但是我用的ide是eclipse,相对于书我的版本比较新


一开始这两行老是报错,我尝试了各种办法,不能解决(因为是在jsp页面),然后就看到下面这个帖子,照着最后一步设置了我的eclipse,虽然跟方法有的地方有出入,但是错误毕竟解决了



(上面两个窗口是通过右击项目选择properties调出)

的问题就解决了,快看


List<User> users = new ArrayList<User>();

在左边出现一个小红叉,报错:

"Syntax error,parameterized types are only available if source level is 5.0"

说明编译环境不是在5.0,但是MyEclipse中应用的jdk明明是1.5或以上版本。

有两种方法处理:

一种是Myeclipse对所有项目默认的设置是5.0以下,项目继承了默认设置(在Myeclipse IDE中的菜单Window/Preferences/Java/Compiler里改为5.0或高于5.0)

另一种是单个项目里设置了source level 5.0以下(在项目属性/Java Compiler 里改为5.0或高于5.0)

在myeclipse里引入新项目的时候会报如下错误:

在使用泛型的地方提示:

Multiple markers at this line 
- Syntax error, parameterized types are only available if source level 
is 5.0 
- The type List is not generic; it cannot be parameterized with 
arguments <Application>

1)一种是Eclipse对所有项目默认的设置是5.0以下,项目继承了默认设置(在Preferences/Java/Compiler里改为5.0或高于5.0)
另一种是项目里设置了source level 5.0以下(在 项目属性/Java Compiler 里改为5.0或高于5.0)

 

你的JDK 版本比较旧,或者你装了比较新的版本,但是你在Eclipse中的设置有问题,编译级别设置的不是比较新的版本的编译器。
eclipse措无题诗如下: 
Multiple markers at this line 
- Syntax error, parameterized types are only available if source level 
is 5.0 
译:语法错误 ,泛型只有在5.0以上的版本才支持 

The type List is not generic; it cannot be parameterized with 
arguments <Application> 
List 不是泛型,引起的原因还是编译器不支持~~ 

这时候需要改动两个地方:

1.右击项目-->properties-->java compiler -->选择enabel project specific setting -->Compiler compliance level :选择1.5版本,其他默认

2.右击项目-->properties -->project facets-->将java后的下拉框选择为5.0


阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页