Description
现在请求你维护一个数列,要求提供以下两种操作:1、 查询操作。语法:Q L 功能:查询当前数列中末尾L
个数中的最大的数,并输出这个数的值。限制:L不超过当前数列的长度。2、 插入操作。语法:A n 功能:将n加
上t,其中t是最近一次查询操作的答案(如果还未执行过查询操作,则t=0),并将所得结果对一个固定的常数D取
模,将所得答案插入到数列的末尾。限制:n是非负整数并且在长整范围内。注意:初始时数列是空的,没有一个
数。
Input
第一行两个整数,M和D,其中M表示操作的个数(M <= 200,000),D如上文中所述,满足D在longint内。接下来
M行,查询操作或者插入操作。
Output
对于每一个询问操作,输出一行。该行只有一个数,即序列中最后L个数的最大数。
Sample Input
5 100
A 96
Q 1
A 97
Q 1
Q 2
A 96
Q 1
A 97
Q 1
Q 2
Sample Output
96
93
96
93
96
用线段树怼的,题目要求后面+一个数字 那么就初始化线段树为M个数字就好了,每次后面更新新的值就好了
#include<cstdio>
#include<queue>
#include<iostream>
#include<cmath>
#define LL long long
#define For(i,N) for(int i=1;i<=N;i++)
const LL mod =100003;
using namespace std;
LL N,M,T,D;
const int maxn=2000000+1000;
LL W[maxn<<2]={0};
void pushup(int x)
{
int l=x<<1,r=x<<1|1;
W[x]=max(W[x],W[l]);
W[x]=max(W[x],W[r]);
}
void build(int L,int R,int x)
{
if(L==R)
{
W[x]=0;
return ;
}
int mid=(L+R)>>1;
build(L,mid,x<<1);
build(mid+1,R,x<<1|1);
pushup(x);
}
void update(int f,LL w,int x,int L,int R)
{
if(L==R&&L==f)
{
W[x]=w;
return ;
}
int mid=(L+R)>>1;
if(f<=mid)
update(f,w,x<<1,L,mid);
else
update(f,w,x<<1|1,mid+1,R);
pushup(x);
}
LL quary(int L,int R,int l,int r,LL x)
{
if(R<l||L>r)return 0;
if(l<=L&&r>=R)
{
return W[x];
}
int mid=(L+R)>>1;
LL a=quary(L,mid,l,r,x<<1);
LL b=quary(mid+1,R,l,r,x<<1|1);
return max(a,b);
}
int main()
{
//freopen("werw.txt","w",stdout);
scanf("%lld%lld",&M,&D);
N=M+1;
LL n=0,t=0;
build(1,N,1);
char S[10];
For(i,M)
{
LL x;
scanf("%s",S);
if(S[0]=='A')
{
scanf("%lld",&x);
update(++n,(x+t)%D,1,1,N);
}
else
{
scanf("%lld",&x);
LL r=n;
LL l=n-x+1;
LL ans=quary(1,N,l,r,1);
t=ans;
printf("%lld\n",ans);
}
}
return 0;
}
/*
5 97
A 96
Q 1
A 96
Q 1
Q 2
*/