水仙花数

习题4-6 水仙花数   (20分)

水仙花数是指一个NN位正整数(N\ge 3N3),它的每个位上的数字的NN次幂之和等于它本身。例如:153 = 1^3 + 5^3+ 3^3153=13+53+33。 本题要求编写程序,计算所有NN位水仙花数。

输入格式:

输入在一行中给出一个正整数NN3\le N\le 73N7)。

输出格式:

按递增顺序输出所有NN位水仙花数,每个数字占一行。

输入样例:

3

输出样例:

153
370
371
407

#include <stdio.h>  
#include <math.h>
  
int narcissistic( int num,int n);  
void PrintN(int n);  
  
int main()  
{  
    int n;
  
    scanf("%d",&n);  
    PrintN(n);  
  
    return 0;  
}  

int narcissistic( int num, int n){
	int i,sum=0,tmp;  

	tmp=num;
    while(tmp){
		i=tmp%10;
        sum += (int)pow(i, n);
        tmp/=10; 
    }  
  
    if(sum == num)  
        return 1;  
    else  
        return 0;  

}

void PrintN(int n ){  
  
    int i,from,to;  

	from=(int)pow(10,(n-1));
	to=(int)pow(10,n);

	printf("from = %d, to = %d\n", from ,to);
  
    for(i=from;i<to;i++)
        if(narcissistic(i, n))  
            printf("%d\n", i);
}  




  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值