深度优先搜索 (DFS)


   写在前面的话:搜索问题第一次接触,感觉很陌生,所以只有向大神请教!看看代码也不是很难,就是有一两处比较难懂,特此剪切,深度分析:不就快懂,只求能会。慢慢摸索吧!
A - Lake Counting
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

 

A - Lake Counting
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.       

Given a diagram of Farmer John's field, determine how many ponds he has.     

Input

       * Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.     

Output

       * Line 1: The number of ponds in Farmer John's field.     

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

answer:

#include<stdio.h>
#include<string.h>
int n,m;
char s[104][104];
int dir[8][2]= {-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};  // 二维数组,定义一个坐标的四周!八行二列。
bool vis[104][104];
void dfs(int x,int y)      //调用函数:DFS的精髓,也是最难理解的部分!
   {
    int i;
    if(x<0||x>=n||y<0||y>=m||vis[x][y]||s[x][y]=='.')    // 判定条件:池塘的边界!
      return;
 
          vis[x][y]=1;
    for(i=0; i<8; i++)
         dfs(x+dir[i][0],y+dir[i][1]);      //判断该坐标的四周,不满足if,就标记为1.  
              }
 int main()
{
    int i,j,ans;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(s,0,sizeof(s));
         memset(vis,0,sizeof(vis));     //把所有数标记为零!表明未被、标记前为零
        ans=0;
        for(i=0; i<n; i++)
            scanf("%s",s[i]);
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                if(s[i][j]=='W'&&!vis[i][j])      //判断是否标记并且是否为池塘!
                {
                    ans++;
                    dfs(i,j);
                }
        printf("%d\n",ans);
    }
    return 0;
}


 


#include<stdio.h>
#include<string.h>
int n,m;
char s[104][104];
int dir[8][2]= {-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};
bool vis[104][104];
void dfs(int x,int y)
{
    int i;
    if(x<0||x>=n||y<0||y>=m||vis[x][y]||s[x][y]=='.') return;
    vis[x][y]=1;
    for(i=0; i<8; i++)
        dfs(x+dir[i][0],y+dir[i][1]);
}
int main()
{
    int i,j,ans;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(s,0,sizeof(s));
        memset(vis,0,sizeof(vis));
        ans=0;
        for(i=0; i<n; i++)
            scanf("%s",s[i]);
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                if(s[i][j]=='W'&&!vis[i][j])
                {
                    ans++;
                    dfs(i,j);
                }
        printf("%d\n",ans);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值