刷水题,找自信。。。
Holding Bin-Laden Captive!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16075 Accepted Submission(s): 7212
Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
Sample Input
1 1 3 0 0 0
Sample Output
4
解答:
/*方法一:找规律,若1的个数为0的话,则没有偶数,
else若前两个数相加不足4,那么不足4,其他情况则
就是可以满足,一直到三个数组成的最大值*/
#include<stdio.h>
int main()
{
int a,b,c,t;
while(scanf("%d%d%d",&a,&b,&c)!=EOF)
{
if(a==0&&b==0&&c==0)
break;
int t=1*a+b*2+c*5;
if(a==0)
printf("1\n");
else if(a+b*2<4)
printf("%d\n",a+b*2+1);
else
printf("%d\n",t+1);
}
}
/*方法二:判定,从最小的开始判定,如果不能被整除,说明达不到这个数,*/
#include<stdio.h>
int main()
{
int a,b,c;
int j,t;
while(~scanf("%d%d%d",&a,&b,&c),a||b||c)
{
for(j=1;;j++)
{
t=j;
if(t<=c*5)
t=t%5;
else
t=t-c*5;
if(t<=b*2)
t=t%2;
else
t=t-b*2;
if(t<=a)
t=0;
if(t!=0)
break;
}
printf("%d\n",j);
}
return 0;
}
Author
lcy
解答