N!

A - N!
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! 
 

Input

One N in one line, process to the end of file. 
 

Output

For each N, output N! in one line. 
 

Sample Input

     
     
1 2 3
 

Sample Output

     
     
1 2 6
题目虽然简单,但是体现的是一种思想!用数组保存数据,学会这个方法,妈妈再也不用担心我学习了耶!!
解答:
#include<stdio.h>
#include<string.h>
int main()
{
    int a,i,j;
    int d[35662];//10000的阶乘为35660位,所以用这么大的数组。
    int s,c;
    while(scanf("%d",&a)!=EOF)
    {

            memset(d,0,sizeof(d));//初始化数据,另其为零
                d[0]=1;//门户
            for(i=2;i<=a;i++)
            {
              c=0;//存储余数
                for(j=0;j<=35661;j++)
                {
                    s=i*d[j]+c;
                    d[j]=s%10;
                    c=s/10;
                }
            }
            for(i=35661;i>=0;i--)//除去前面的零
            if(d[i])
            break;
            for(j=i;j>=0;j--)//由高位到低位输出
            printf("%d",d[j]);
            printf("\n");

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值