Code

E - Code
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55
当时看到这个题目,一点想法也没有,看到说是利用杨辉三角,就想不通为什么,
原来竟然用到二项式的方式。呵呵,真服了,数学的魅力真是无穷,这个题目的要求是:
只有一次输入,输入一个字符串,必须保证字符串的字符满足字母表,也就是字符串前面的
要后面对应的字符小,若不满足,输出0,这个题目最难想到的是字符的长度可以代表数字,
a~z有二十六个,ab~az有二十五个,...yz为一个,所以二位有C(2,26);三位有
C(3,26)个。杨辉三角的第27行,第四个数就是C(3,26);
例如:计算adfg;
就要先计算abcd;
然后在加上其他的部分。
#include<stdio.h>
#include<string.h>
int c[27][27];  
void yanghui()  //杨辉三角可以求解二项式
{  
   int i,j;  
   for(i=0;i<=26;i++)  
   {  
       for(j=0;j<=i;j++)  
       {  
           if(!j||i==j)  
           c[i][j]=1;  
           else  
           c[i][j]=c[i-1][j-1]+c[i-1][j];  
       }  
   }  
   return;  
}  
int main()  
{  
    yanghui();  
    char s[17];  
    int i,j;  
    scanf("%s",s);  
    int t=strlen(s);  
    for(i=1;i<t;i++)//判定是否满足最基本条件。  
    {  
         if(s[i-1]>=s[i])  
         {  
             printf("0\n");  
             return 0;  
         }  
    }  
    int sum=0;  
    for(i=1;i<t;i++)  
    {  
         sum+=c[26][i]; //首先 把最基本的加上。
    }  
   for(i=0;i<t;i++)  
   {  
        char dan;
        if(i==0)
        dan='a';
        else
        dan=s[i-1]+1; //判定若为第一个则减数为a,
        //否则为前一个数多对应的字母数加一
        //(因为要求为后者不能比前面的大,相等也不行) 
        while(dan<=s[i]-1)  
        {  
             sum+=c['z'-dan][t-1-i];  //前面完成了大部分,现在就就是加上剩下的
            dan++;  
        }  
   }  
      printf("%d\n",sum+1);  //再加上自身
    return 0;  
}  


 
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值