hdu 5113 Black And White

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1173    Accepted Submission(s): 306
Special Judge

Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
  
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
  
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 
题意:给一个n*m的矩阵和k种染料,每种染料要染ai个方格,保证a1 + a2 +...+ ak = n * m,给这个矩阵染色,要求相邻方格颜色不能相同。
思路:没想到是个简单的剪枝搜索。。。只需要在开始判断一下颜色最多的方格个数是不是超过了(n + m + 1)/ 2就可以了。。。
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct Color {
    int color, n;
    bool operator < (const Color &i) const {
        return n > i.n;
    }
}color[30];
int mp[10][10], n, m, k;
bool dfs(int x, int y) {
    if(x == n) return true;
    if(y == m) return dfs(x + 1, 0);
    for(int i = 1; i <= k; i++) {
        if(color[i].n) {
            if(x && mp[x - 1][y] == color[i].color) continue;
            if(y && mp[x][y - 1] == color[i].color) continue;
            mp[x][y] = color[i].color;
            color[i].n--;
            if(dfs(x, y + 1)) return true;
            color[i].n++;
        }
    }
    return false;
}
main() {
    int t;
    scanf("%d", &t);
    for(int cas = 1; cas <= t; cas++) {
        scanf("%d %d %d",&n, &m, &k);
        for(int i = 1; i <= k; i++) {
            scanf("%d", &color[i].n);
            color[i].color = i;
        }
        sort(color + 1, color + 1 + k);
        printf("Case #%d:\n", cas);
        if(color[1].n > (n * m + 1) / 2) {
            puts("NO");
            continue;
        }
        if(dfs(0,0)) {
            puts("YES");
            for(int i = 0; i < n; i++){
                for(int j = 0; j < m; j++)
                    if(!j) printf("%d", mp[i][j]);
                    else printf(" %d", mp[i][j]);
                putchar('\n');
            }
        }
        else puts("NO");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值