PAT 1016. Phone Bills (25)

1016. Phone Bills (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80

Total amount: $638.80

题目解析:

本题要做的是从一堆乱序的电话拨出和挂断的时间记录中找到相匹配的拨出和挂断时间,然后根据输入的24小时收费标准计算费用。

要做的就是:1)对电话记录进行配对;2)计算费用。

考察重点:

数据封装与处理

注意点:

费用是根据每个小时的不同分别计算的。

题目保证每条记录属于同一个月。

结果输出需要注意时间和价格格式,需要对人名进行排序。

本份代码思路:

Records类保存同一个人的拨出和挂断记录。

Time类封装时间。

使用Map<name,Records>保存所有记录。

import java.text.NumberFormat;
import java.util.HashMap;
import java.util.LinkedList;
import java.util.Map;
import java.util.Scanner;
import java.util.Set;
import java.util.TreeSet;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int[] toll = new int[24];
		int N;
		for (int i = 0; i < 24; i++) {
			toll[i] = scanner.nextInt();
		}
		N = scanner.nextInt();
		//preserve call records in the mapping of people's name and call records
		Map<String, Records> map = new HashMap<String, Records>();
		String name = "";
		String time = "";
		String on_off = "";
		String month = "";
		Records records = null;
		for (int i = 0; i < N; i++) {
			name = scanner.next();
			time = scanner.next();
			month = time.substring(0, 2);
			on_off = scanner.next();
			if (map.containsKey(name)) {
				records = map.get(name);
				records.add(new Time(time), on_off.equals("on-line"));
				map.put(name, records);
			} else {
				map.put(name, new Records(new Time(time), on_off.equals("on-line")));
			}
		}
		scanner.close();
		int totalPrice = 0;
		int curPrice = 0;
		Time time_on = null;
		Time time_off = null;
		Set<String> set = new TreeSet<String>();
		for (String key : map.keySet()) {
			set.add(key);
		}
		//for everybody who make call
		for (String nameKey : set) {
			records = map.get(nameKey);
			totalPrice = 0;
			int index_on = 0;
			int index_off = 0;
			//search for correct relationship between on-line and off-line record
			while (index_on < records.onList.size() && index_off < records.offList.size()) {
				time_off = records.offList.get(index_off);
				while (index_on < records.onList.size() - 1 && time_off.bigger(records.onList.get(index_on + 1)))
					index_on++;
				time_on = records.onList.get(index_on);
				if (time_off.bigger(time_on)) {
					if (totalPrice == 0) {
						System.out.println(nameKey + " " + month);
					}
					curPrice = getPrice(time_on, time_off, toll);
					//output one call bill
					System.out.print(time_on.getDayHourMin() + " " + time_off.getDayHourMin() + " "
							+ time_off.getSubMinute(time_on) + " ");
					System.out.printf("$%.2f\n", curPrice / 100.0);
					totalPrice += curPrice;
					index_on++;
					index_off++;
				} else {
					index_off++;
				}
			}
			//output total bill
			if (totalPrice != 0) {
				System.out.printf("Total amount: $%.2f\n", totalPrice / 100.0);
			}

		}
	}
	//calculate cost
	static int getPrice(Time time_on, Time time_off, int[] toll) {
		int price = 0;
		int day = time_on.day;
		int hour = time_on.hour;
		int min = time_on.min;
		//Make the same number of days
		while (day < time_off.day) {
			price += toll[hour] * (60 - min);
			min = 0;
			hour++;
			while (hour < 24) {
				price += toll[hour++] * 60;
			}
			hour = 0;
			day++;
		}
		//Make the same number of hours
		while (hour < time_off.hour) {
			price += toll[hour] * (60 - min);
			hour++;
			min = 0;
		}
		//Make the same number of minute
		price += toll[hour] * (time_off.min - min);
		return price;
	}
}
//preserve the call record for same people
class Records {
	LinkedList<Time> onList;
	LinkedList<Time> offList;

	Records(Time time, boolean isOn) {
		onList = new LinkedList<Time>();
		offList = new LinkedList<Time>();
		add(time, isOn);
	}

	void add(Time time, boolean isOn) {
		if (isOn)
			add(onList, time);
		else
			add(offList, time);
	}

	void add(LinkedList<Time> list, Time time) {
		int i;
		for (i = 0; i < list.size(); i++) {
			if (list.get(i).bigger(time)) {
				list.add(i, time);
				return;
			}
		}
		list.add(time);
	}

}

class Time {
	static NumberFormat nf = NumberFormat.getInstance();

	static {
		nf.setMinimumIntegerDigits(2);
	}

	int month;
	int day;
	int hour;
	int min;

	public Time(int month, int day, int hour, int min) {
		super();
		this.month = month;
		this.day = day;
		this.hour = hour;
		this.min = min;
	}

	public Time(String time) {
		super();
		final String[] split = time.split(":");
		this.month = Integer.valueOf(split[0]).intValue();
		this.day = Integer.valueOf(split[1]).intValue();
		this.hour = Integer.valueOf(split[2]).intValue();
		this.min = Integer.valueOf(split[3]).intValue();
	}

	public boolean bigger(Time t) {
		return this.day * 24 * 60 + this.hour * 60 + this.min > t.day * 24 * 60 + t.hour * 60 + t.min;
	}

	public int getSubMinute(Time t) {
		return (this.day - t.day) * 24 * 60 + (this.hour - t.hour) * 60 + (this.min - t.min);
	}

	public String getDayHourMin() {
		return nf.format(day) + ":" + nf.format(hour) + ":" + nf.format(min);
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值