UVA 1640(数位统计)

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu

Status

Description

Download as PDF

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be

1024 1025 1026 1027 1028 1029 1030 1031 1032
there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input 

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output 

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input 

1 10
44 497 
346 542 
1199 1748 
1496 1403 
1004 503 
1714 190 
1317 854 
1976 494 
1001 1960 
0 0

Sample Output 

1 2 1 1 1 1 1 1 1 1 
85 185 185 185 190 96 96 96 95 93 
40 40 40 93 136 82 40 40 40 40 
115 666 215 215 214 205 205 154 105 106 
16 113 19 20 114 20 20 19 19 16 
107 105 100 101 101 197 200 200 200 200 
413 1133 503 503 503 502 502 417 402 412 
196 512 186 104 87 93 97 97 142 196 
398 1375 398 398 405 499 499 495 488 471 
294 1256 296 296 296 296 287 286 286 247

Source

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 10. Maths :: Examples

Status


统计区间里0到9每个数字出现了多少次,直接数学瞎搞

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 10 + 10;
typedef long long ll;
#define foreach(it,v) for(__typeof((v).begin()) it = (v).begin(); it != (v).end(); ++it)
typedef long long ll;
int c[maxn][maxn];
void init(int n)
{
    for(int i = 0; i <= n; i++) {
        c[i][0] = 1;
        for(int j = 1; j <= i; j++) c[i][j] = c[i-1][j-1] + c[i-1][j];
        c[i][i+1] = 0;
    }
}
ll quick(int a,int n)
{
    ll res = 1,b = a;
    while(n>0) {
        if(n&1)res *= b;
        b = b*b;
        n>>=1;
    }
    return res;
}
ll work(int f,int k,int L,int tot)/*计算以f开头长为L且之前已经出现tot个k的数字里有多少个k*/
{
    ll res = 0;
    if(f==k)tot++;
    for(int i = 0; i < L; i++) {
        res += (i+tot)*c[L-1][i]*quick(9,L-1-i);
    }
    return res;
}
ll solve(const char *s,int k)/*计算[1,s)里的数字一共有多少个k*/
{
    int sz = strlen(s);
    ll res = 0,tot = 0;
    for(int i = 1; i < s[0]-'0'; i++)res += work(i,k,sz,0);
    for(int L = 1; L < sz; L++) {
        for(int i = 1; i < 10; i++)
            res += work(i,k,L,0);
    }
    if(s[0]-'0'==k)tot++;
    for(int i = 1; i < sz; i++) {
        int limt = s[i] - '0';
        for(int j = 0; j < limt; j++) {
            res += work(j,k,sz-i,tot);
        }
        if(limt==k)tot++;
    }
    return res;
}
int main()
{
    init(12);
    int L,R;
    while(~scanf("%d%d",&L,&R)) {
        if(L+R==0)return 0;
        if(L>R)swap(L,R);
        char sl[20],sr[20];
        sprintf(sl,"%d",L);
        sprintf(sr,"%d",R+1);
        for(int i = 0; i < 10; i++)
            printf("%lld%c",solve(sr,i)-solve(sl,i)," \n"[i==9]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值