大数问题 *

问题 N : A + B Problem II
时间限制:1 秒内存限制:32 兆特殊判题: 否 提交:58解决: 10
标签
输入输出练习
题目描述
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
 
输入格式
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
 
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
 
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3


Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
提示[+]
*** 提示已隐藏,点击上方 [+] 可显示 ***
分类
杭电OJ(HDOJ)原题
#include<stdio.h>
#include<string.h>
int main()
{
int a[1002]={0},b[1002]={0},c[1002]={0};
int ka,kb,k,i,n,h=1;
char a1[1002],b1[1002];
scanf("%d",&n);
while(n--)
{ scanf("%s",a1) ;ka=strlen(a1);
scanf("%s",b1);kb=strlen(b1);
if(ka>kb) k=ka;
else k=kb;
for(i=0;i<ka;i++) a[i]=a1[ka-1-i]-'0';
for(i=0;i<kb;i++) b[i]=b1[kb-1-i]-'0';
for(i=0;i<k;i++)
{
c[i]=a[i]+b[i]+c[i];
c[i+1]=c[i+1]+c[i]/10;
c[i]=c[i]%10;
}
if(c[k]) k++;
printf("Case %d:\n",h++);
printf("%s + %s = ",a1,b1);
for(i=k-1;i>=0;i--) printf("%d",c[i]);
if(n>=1) 
printf("\n\n");
else
printf("\n");
for(i=k-1;i>=0;i--) c[i]=0;
for(i=0;i<ka;i++) a[i]=0;
for(i=0;i<kb;i++) b[i]=0;

return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值