1015 Number Sequence

1015 Number Sequence

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 106977    Accepted Submission(s):25999


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

 

Input

The input consists of multiple test cases.Each test case contains 3 integers A, B and n on a single line (1 <= A, B<= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of inputand this test case is not to be processed.

 

 

Output

For each test case, print the value of f(n)on a single line.

 

 

Sample Input

1 1 3

1 2 10

0 0 0

 

 

Sample Output

2

5

#include<iostream>
using namespace std;
int main()
{
int f[100];
f[1]=1,f[2]=1;
int a,b,i,n;
while((cin>>a>>b>>n)&&(a||b||n))
{
for(i=3;i<=49;i++)
{f[i]=(a*f[i-1]+b*f[i-2])%7;
}
n=n%49;
cout<<f[n]<<endl;
}
return 0;
}

这个题目是暑假做的了,开始第一次是就是纯粹暴力破解的,但是超时了,后来才找规律的,发现对7取余之后得到的书只能为0-6之间,而每一个f[n]又由开始的f[n-1]和f[n-2]所决定,也就是说要想重复,这个最大达到7*7=49时是必然重复的,所以通过这点得出了它的最大周期数,从而减少了它的运行时间。

做这类题的时候应该想办法去找最大的周期,没必要真的一个一个的去找,还有做这种数据量很大的题时去找规律,用数组来解决问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值