HDU-1016 Prime Ring Problem

Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 


 

Input

n (0 < n < 20). 
 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
 

Sample Input

    
    
6 8
 

Sample Output

    
    
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

题解:前一个和当前个相加是否是素数,是素数就输出,就是按相邻相加是否素数,最后一个就和第一个判断。一定是偶数个输出。

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;

int n;
int pic[22];
bool vis[22];
bool isprime(int num){
    int up = floor(sqrt(num)+0.5);
    for(int i = 2; i <= up;i++)
        if(num%i == 0) return false;
    return true;
}

void init(){
    memset(vis,false,sizeof(vis));
    vis[1] = true;
    pic[1] = 1;
}

void dfs(int num){
    if(num == n && isprime(pic[1]+pic[n])){
        for(int i = 1; i <= n-1; i++)
            cout<<pic[i]<<" ";
        cout<<pic[n]<<endl;
    }else{
        for(int i = 2; i <= n; i++){
            if(!vis[i] && isprime(i+pic[num])){
                vis[i] = true;
                pic[num+1] = i;
                dfs(num+1);
                vis[i] = false;
            }
        }
    }
}

int main(){
    int c = 0;
    while(cin>>n){
        cout<<"Case "<<++c<<":"<<endl;
        init();
        dfs(1);
        cout<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值