Description
Problem E Watering Grass Input: standard input Output: standard output Time Limit: 3 seconds
n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?
Input
Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)
Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.
Sample input
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
Sample Output
62
-1
(Regionals 2002 Warm-up Contest, Problem setter: Piotr Rudnicku)
题意:最少用多少圆可以覆盖整个草坪。这是个区间覆盖问题,有圆的性质可知,把不能覆盖草坪宽度就去掉,然后把left进行排序,取出最优值
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 10005;
struct node{
double r,l;
}N[maxn];
bool cmp(node a,node b){
return a.l < b.l;
}
int n;
double w,l;
double centre,r;
int main(){
while(scanf("%d%lf%lf",&n,&l,&w) == 3){
int inde = 0;
for(int i = 0; i < n ; i++){
scanf("%lf%lf",¢re,&r);
if(w/2 >= r) continue;
double d = sqrt(r*r - w*w/4.0);
N[inde].l = centre-d;
N[inde++].r = centre+d;
}
sort(N,N+inde,cmp);
double r1 = 0,l1 = 0;
int i = 0;
int R_max = 0;
int sum = 0;
bool check = false;
if(N[0].l <= 0){
while(i < inde){
R_max = i;
while(l1>=N[R_max].l && R_max < inde){ //找出最长R
if(r1 < N[R_max].r) r1 = N[R_max].r;
R_max++;
}
if(i == R_max) break;
i = R_max;
sum++;
l1 = r1;
if(l1 >= l){check = true;break;}
}
}
printf("%d\n",check?sum:-1);
}
return 0;
}