POJ - 1200Crazy Search(哈希|hash)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29445 Accepted: 8176

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”; “aab”; “aba”; “bab”; “bac”. Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source

Southwestern Europe 2002

题意:

给定一个只有nc个不同字符的字符串,然后问有多少个不同长度为n的子串

对于每种不同的字符编号,然后对长度为n的字符串值进行nc进制编码,加入哈希表里(类似桶排,感觉用map或者set会T掉),一般情况要取模挂链哈希,然而本题数据没有卡,所以就这样。

#include<cstdio>
#include<cstring>
//#include<map>
using namespace std;
typedef long long LL;
const int maxn=16e6+5;
//map<LL,bool>Q;
char s[maxn];
bool Q[maxn];
int a[300],len,n,k;
LL res,ans,base;
int main()
{
  while(~scanf("%d%d",&n,&k))
  {
    int cnt=0; 
    memset(Q,0,sizeof(Q));
    scanf("%s",s+1);
    len=strlen(s+1);

    for(int i=1;i<=len;++i)
    {
      if(!a[s[i]])a[s[i]]=cnt++;
      if(cnt==k)break; 
    }

    res=0;base=1;ans=0;
    for(int i=1;i<=n;++i)
    {
      res=res*k+a[s[i]];
      base*=k;
    }

    base/=k;
    Q[res]=1;++ans;
    //printf("%d\n",res);

    for(int i=n+1;i<=len;++i)
    {
      res=(res-base*a[s[i-n]])*k+a[s[i]];
      //printf("%d\n",res);
      if(!Q[res])
      {
        Q[res]=1;
        ans++;
      }
    }

    printf("%lld\n",ans);
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值