POJ 1200 Crazy Search (哈希)

题目链接

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

分析:
给定一个有nc个不同的字符组成的字符串,然后询问这个字符串里面有多少个长度为n的不完全相同的子串。

首先想到的就是对于这个字符串使用字符串截取函数获取每一个子串,然后利用map来判重。但是这样的话时间会超时,转换一下利用hash的思想来求解。

明确指出是该字符串由nc个不同的字符组成,我们将这nc个字符串对应成nc进制,对应的时候与字符的ASCLL码表没有关系,至于该字符第一次在字符串中出现的顺序有关(当然这个可以根据自己的习惯来定义)
例如题目上给出的:daababac
对应成 4进制后是:01121213

然后根据转换后的进制数,将每一个子串对应成一个一一对应的数字,就可以利用hash在O(1)的时间内进行判重,会大大减少时间。

需要注意的一点就是,因为我们是按照nc进制来求数值的,而不是习惯所有的10进制,说以应该乘上的是nc。

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int num[300];
int Hash[16000009];//hash函数
int main()
{
    int n,nc;
    string str;
    while(~scanf("%d%d",&n,&nc))
    {
        memset(Hash,0,sizeof(Hash));
        cin>>str;
        int len=str.length();
        int cnt=1;
        num[str[0]]=0;
        for(int i=1; i<len; i++) //将nc个字符转换为对应的nc进制的数,字母和数字是一一对应的
        {
            if(num[str[i]]==0)//只有当这个字符没有转换过的时候,才将该字符对应成一个数字
            {
                num[str[i]]=cnt;
                cnt++;
            }
        }
        int ans=0,sum;
        for(int i=0; i<=len-n; i++)
        {
            sum=0;
            for(int j=i; j<i+n; j++)
            {
                sum=sum*nc+num[str[j]];//特别要注意这里因为是nc进制的计算所以乘上的是nc,不要因为我们习惯的十进制计算而乘上10
            }
            //这样每一个长度为n的不同的子串都会唯一的对应一个数字
            if(Hash[sum]==0)
            {
                Hash[sum]=1;
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

转载于:https://www.cnblogs.com/cmmdc/p/8776628.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值