POJ - 2002Squares(哈希or set|离散)

3 篇文章 0 订阅
3 篇文章 0 订阅

Squares

Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 20520 Accepted: 7887

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

Rocky Mountain 2004

题意:

给定n个个点,问能组成多少个矩形

n<=1000,很容易想到,枚举一条边,每条边最多是两个不同矩形的边,每次把边顺时针转90,逆时针转90去找其他两个点是否存在

判是否存在可以利用set,元素为点,每次去find即可(可能会T,程序3485ms爬过。。稳得不对。。时限3.5s=3500ms)

也可以哈希,key=(100001*x+y)%mod,再加挂链哈希

更容易想到的,如果直接暴力就开bool数组判vis[X][Y]是否存在,那么我们只需要把x,y离散化,最多只有n个值,每次计算出其他正方形的点,去离散完的横纵坐标找新的X’,Y’,然后直接vis[X’][Y’]即可时间复杂度O(N^2logN),应该是最优且不会退化的了,有空再更离散的代码

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<cmath>
using namespace std;
const int maxn=1000+5;
//typedef pair<int,int> pai;
struct pai
{
  int x,y;
  bool operator <(const pai&B)const 
  {
    return (x<B.x)||(x==B.x&&y<B.y);
  }
}a[maxn];
int ans,n;
set<pai>Q;

int main()
{
  while(~scanf("%d",&n))
  {
    if(!n)break;
    ans=0;
    Q.clear();
    for(int i=1;i<=n;++i)
    {
      scanf("%d%d",&a[i].x,&a[i].y);
      Q.insert(a[i]);
    }

    for(int i=1;i<=n;++i)
      for(int j=i+1;j<=n;++j)
      {
        pai tmp,n1,n2;
        tmp.x=a[i].x-a[j].x;
        tmp.y=a[i].y-a[j].y;

        n1.x=a[i].x-tmp.y;
        n1.y=a[i].y+tmp.x;
        n2.x=a[j].x-tmp.y;
        n2.y=a[j].y+tmp.x;
        if((Q.find(n1)!=Q.end())&&(Q.find(n2)!=Q.end()))++ans;

        tmp.x=-a[i].x+a[j].x;
        tmp.y=-a[i].y+a[j].y;

        n1.x=a[i].x-tmp.y;
        n1.y=a[i].y+tmp.x;
        n2.x=a[j].x-tmp.y;
        n2.y=a[j].y+tmp.x;
        if((Q.find(n1)!=Q.end())&&(Q.find(n2)!=Q.end()))++ans;
      }
    printf("%d\n",ans/4);
  }
  return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值