C++一行输入多个整数,每个整数用空格隔开,回车结束输入

C++一行输入多个整数,每个整数用空格隔开,回车结束输入

#include <bits/stdc++.h>
using namespace std;
char c;
int a[1001], n;
int main()
{
	do{
		scanf("%d", &a[n]);
		n++;	
	}while(c=getchar()!='\n');
	
	for(int i=0; i<n; ++i){
		cout << a[i] << " ";
	}
	return 0;
}

找最大数序列

http://noi.openjudge.cn/ch0109/10/

描述

输入n行,每行不超过100个无符号整数,无符号数不超过4位。请输出最大整数以及最大整数所在的行号(行号从1开始)。如果该数据在多个行中出现,则按从小到大输出相应行号,行号之间以一个逗号分开。

输入

一行输入一个正整数n(n <= 30)。
之后的n行,每行包含不超过100个无符号整数,整数之间以一个逗号分开。

输出

第一行:最大整数;
第二行:最大整数所在的行编号,逗号间隔。

样例输入

6
1,3,5,23,6,8,14
20,22,13,4,16
23,12,17,22
2,6,10,9,3,6
22,21,20,8,10
22,1,23,6,8,19,23

样例输出

23
1,3,6
#include <bits/stdc++.h>
using namespace std;
int n, a[35][111], mmax, ans[111], cnt;
int main()
{
	cin >> n;
	for(int i=1; i<=n; ++i){
		int j=1;
		while(cin>>a[i][j]){
			if(a[i][j]>mmax){
				mmax=a[i][j];
			}
			char c=getchar();
			if(c==','){
				j++;
			}
			else if(c=='\n'){
				a[i][0]=j; 
				break;
			}
		}
	}
	for(int i=1; i<=n; ++i){
		for(int j=1; j<=a[i][0]; ++j){
			if(a[i][j]==mmax){
				cnt++;
				ans[cnt]=i;
				break;
			} 
		}
	}
	cout << mmax << endl;
	for(int i=1; i<cnt; ++i){
		cout << ans[i] << ",";
	}
	cout << ans[cnt];
	return 0;	
}

 

  • 10
    点赞
  • 24
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 7
    评论
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ypeijasd

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值