Description
Artificial Intelligence?
Artificial Intelligence? |
Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!
So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".
However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."
OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)
Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.
Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.
Input
The first line of the input file will contain the number of test cases.Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.
Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:
DataField ::= Concept '=' RealNumber [Prefix] Unit Concept ::= 'P' | 'U' | 'I' Prefix ::= 'm' | 'k' | 'M' Unit ::= 'W' | 'V' | 'A'
Additional assertions:
- The equal sign (`=') will never occur in an other context than within a data field.
- There is no whitespace (tabs,blanks) inside a data field.
- Either P and U, P and I, or U and I will be given.
Output
For each test case, print three lines:- a line saying ``Problem #k" where k is the number of the test case
- a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
- a blank line
Sample Input
3 If the voltage is U=200V and the current is I=4.5A, which power is generated? A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please. bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
Sample Output
Problem #1 P=900.00W Problem #2 I=0.45A Problem #3 U=1250000.00V
解题报告
根据P = U * I公式进行计算。
从读入的字符串中提取P,I,U其中的两个变量,输出第三个变量。题目有个地方需要注意,就是单位前面可能有前缀,M表示*1000000,k表示*1000,m表示/1000。
先用数组把等号前面的字符串(包括等号)吃掉,再输入数字和单位,一个案例需要两次重复的输入。
#include<stdio.h>
int main()
{
int n,i,j;
char ch[1000],c;
scanf("%d",&n);
getchar();
for(j=0;j<n;j++)
{
double U=0,P=0,I=0,t;
for(i=0;(ch[i]=getchar())!='=';i++)
;
scanf("%lf%c",&t,&c);
switch(c)
{
case 'M':t*=1000000;break;
case 'k':t*=1000;break;
case 'm':t*=.001;break;
}
switch(ch[i-1])
{
case 'U':U=t;break;
case 'I':I=t;break;
case 'P':P=t;break;
}
for(i=0;(ch[i]=getchar())!='=';i++)
;
scanf("%lf%c",&t,&c);
switch(c)
{
case 'M':t*=1000000;break;
case 'k':t*=1000;break;
case 'm':t*=.001;break;
}
switch(ch[i-1])
{
case 'U':U=t;break;
case 'I':I=t;break;
case 'P':P=t;break;
}
printf("Problem #%d\n",j+1);
if(P > 0 && I > 0)
printf("U=%.2lfV\n",P/I);
else if(U > 0 && P > 0)
printf("I=%.2lfA\n",P/U);
else if(U > 0 && I > 0)
printf("P=%.2lfW\n",I*U);
printf("\n");
}
return 0;
}