The Collatz Sequence

Description


  The Collatz Sequence 

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:
Choose an arbitrary positive integer  A as the first item in the sequence.
Step 2:
If  A = 1 then stop.
Step 3:
If  A is even, then replace  A by  A / 2 and go to step 2.
Step 4:
If  A is odd, then replace  A by 3 *  A + 1 and go to step 2.

It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of  A (for step 1) and the second giving  L, the limiting value for terms in the sequence. Neither of these,  A or  L, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of  A is always less than  L. A line that contains two negative integers follows the last case.

Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for  A, the limiting value  L, and the number of terms computed.

Sample Input 

 3 100
 34 100
 75 250
 27 2147483647
 101 304
 101 303
 -1 -1

Sample Output 

 Case 1: A = 3, limit = 100, number of terms = 8
 Case 2: A = 34, limit = 100, number of terms = 14
 Case 3: A = 75, limit = 250, number of terms = 3
 Case 4: A = 27, limit = 2147483647, number of terms = 112
 Case 5: A = 101, limit = 304, number of terms = 26
 Case 6: A = 101, limit = 303, number of terms = 1



解题报告

英文是硬伤呀,题目不难,说得很清楚了,就是要照步骤一步步敲,一开始使用int出现超时,超时是因为运算过程中出现数据溢出出现负数导致运算无限循环运算,所以超时,用long就行了



#include<stdio.h>
int main ()
{
    int count,i=1;
    long a,s,l;
                              
    while(scanf("%ld %ld",&a,&l)!=EOF)
    {
        if(a<0 && l<0)
        break;
        s=a;
        count=0;
        while(a!=1)
        {
            if(a%2==0)
            {
                a=a/2;
                count++;
            }
            else
            {
                a=3*a+1;
                if(a>l) break;
                else count++;
            }
        }
        printf("Case %d: A = %ld, limit = %ld, number of terms = %d\n",i++,s,l,count+1);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值