POJ训练计划1094_Sorting It All Out(拓扑排序)

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 26348 Accepted: 9120

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

解题报告

题意很难理解,我是看一本书才做这题的,表示没看英语。

在Discuss里看到这样解释的

Sorted sequence determined after 4 relations: ABCD.  
输入前4个关系后,决定出了一个序列(关系总数可能大于4)

Inconsistency found after 2 relations.
输入前2个关系后,冲突出现了(环,关系总数可能大于2)

Sorted sequence cannot be determined.
所有关系输入后,序列和冲突均无出现


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
int n,m,head[30],cnt,d[30];
char tops[1000];
struct node
{
    int v,next;
}edge[100100];
void add(int u,int v)
{
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int topsort(int s)
{
    int dd[30],i,j,u,c=0,f=1,k=0;
    for(i=0;i<n;i++)
        dd[i]=d[i];
    while(s--)
    {
        c=0;
        for(i=0;i<n;i++)
        {
            if(dd[i]==0)
            {
                c++;
                u=i;
            }
        }
        if(c>=1)
        {
            if(c>1)f=0;
            for(i=head[u];i!=-1;i=edge[i].next)
            {
                dd[edge[i].v]--;
            }
            dd[u]--;
            tops[k++]=u+'A';
            tops[k]=0;
        }
        else return -1;
    }
    if(f)
    return k;
    else return 0;
}
int main()
{
    int i,j,k,hash[30],dt=0,c=0;
    char str[4];
    while(cin>>n>>m)
    {
        cnt=0;
        c=0;
        dt=0;
        if(!n&&!m)
        break;
        memset(hash,0,sizeof(hash));
        memset(edge,0,sizeof(edge));
        memset(head,-1,sizeof(head));
        memset(d,0,sizeof(d));
        for(i=0;i<m;i++)
        {
            cin>>str;
            int u=str[0]-'A';
            int v=str[2]-'A';
            add(u,v);
            d[v]++;
            if(!hash[u])
            {
                c++;
                hash[u]=1;
            }
            if(!hash[v])
            {
                c++;
                hash[v]=1;
            }
            if(dt==0)
            {
                int t=topsort(c);
                if(t==-1)
                {
                    dt=-1;
                    k=i+1;
                }
                else if(t==n)
                {
                    dt=1;
                    k=i+1;
                }
            }
        }
        if(dt==1)
        printf("Sorted sequence determined after %d relations: %s.\n",k,tops);
        else if(dt==-1)
        printf("Inconsistency found after %d relations.\n",k);
        else cout<<"Sorted sequence cannot be determined."<<endl;
    }
    return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值