POJ训练计划3687_Labeling Balls(拓扑排序)

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9949 Accepted: 2738

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

解题报告
要注意输出的是从标号1到N的重量,要输出重量,不是标号,还有就是有重边的情况,没有判断重边会导致入度多加。。。
这题要逆向建边,从后往前拓扑排序,才符合题目的要求
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
int d[300],mmap[300][300],n,m,tops[300],ans[300],cnt=0;
void topsort()
{
    int i,j,u;
    for(i=0; i<n; i++)
    {
        u=0;
        for(j=n-1; j>=0; j--)
        {
            if(d[j]==0)
            {
                u=j;
                tops[cnt++]=u;
                d[j]--;
                break;
            }
        }
        for(j=0; j<n; j++)
        {
            if(mmap[u][j])
            {
                d[j]--;
            }
        }
    }
    if(cnt!=n)
        printf("-1\n");
    else
    {
        for(i=0; i<n; i++)
            ans[tops[i]]=n-i;
        for(i=0; i<n-1; i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n-1]);
    }
}
int main()
{
    int t,i,j,u,v;
    cin>>t;
    while(t--)
    {
        cnt=0;
        memset(mmap,0,sizeof(mmap));
        memset(d,0,sizeof(d));
        memset(tops,0,sizeof(tops));
        memset(ans,0,sizeof(ans));
        cin>>n>>m;
        for(i=0; i<m; i++)
        {
            cin>>u>>v;
            if(!mmap[v-1][u-1])
            {
                mmap[v-1][u-1]=1;
                d[u-1]++;
            }
        }
        topsort();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值