[An AC a day]1050_POJ_ACM

C - To the Max
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

#include<stdio.h>

#define N 105

int n,map[N][N];

void input()
{
	scanf("%d",&n);
	for(int i = 1;i<=n;i++)
		for(int j = 1;j<=n;j++)
		{
			scanf("%d",&map[i][j]);
		}
}

int cal_array_max(int a[])
{
	int max = a[1],temp = a[1];
	for(int i = 2;i<=n;i++)
	{
		if(temp>0)
			temp += a[i];
		else
			temp = a[i];
		if(temp > max)
			max = temp;
	}
	return max;
}

int result(int i,int j)
{
	int temp[N] = {0};
	for(int k = 1;k<=n;k++)
		for(int l = i;l<=j;l++)
		{
			temp[k] += map[l][k];
		}
	return cal_array_max(temp);
}

void search()
{
	int max = -1000,temp;
	for(int i = 1;i<=n;i++)
		for(int j = i;j<=n;j++)
		{
			temp = result(i,j);
			if(temp>max)
				max = temp;
		}
	printf("%d\n",max);
}

int  main()
{
	input();
	search();
	
	return 0;
}

还是动态规划的思想。


这道题比较巧妙。他不是直接使用动态规划的思想,而是先将问题转化,转化后再使用动态问题解决转化问题。


为了一个矩阵的最大子阵。解决这道题有点暴力。它以行为单位,result(i,j)表示第i行到第j行间(矩阵的高度必须是j-i+1)的最大子矩阵。即result(i,j)表示的最大子矩阵必须是严格的从第i行开始,在第j行结束,不能在第i和第j行的中间开始或结束。这样,我们最后只需要利用冒泡排序的思想,对起始行和结尾行进行一个遍历,来找到最大值。


而计算第i行到第j行间的最大子矩阵result(i,j),我们将二维的矩阵转化为一维的数列。这只需要我们将矩阵的每一列之和求出来,然后分别放在对应的数组里。


接下来只需要找到数组中数列的子列使的子列的和最大即可。这里,我们就用到了动态规划的方法来求。


我们建立决策:设temp[j]表示以a[j]结尾的子序列的最大和(必须包含a[j])。这个子问题并不是指前j个元素中的最大子列和。而是包含a[j]的最大连续子序列的和。我们只需要求出这样的序列,然后再求出temp数组中的最大值,既可求出最大连续子序列的和。


状态转移方程:temp[j] = max { a[j] , temp[j-1] + a[j] } 。(当temp[j-1]<0时,取a[j]单独。)


根本思想还是对第j个元素a[j]取还是不取得问题,如果取(即可以续接到前面的队伍中),则继续连接。如果不取,则断开。用这样的决策来保证连续。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值