poj解题报告——poj 2028 When Can We Meet?

原题入口

poj 2028 When Can We Meet?

题目描述

When Can We Meet?
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5527 Accepted: 3040

Description
The ICPC committee would like to have its meeting as soon as possible to address every little issue of the next contest. However, members of the committee are so busy maniacally developing (possibly useless) programs that it is very difficult to arrange their schedules for the meeting. So, in order to settle the meeting date, the chairperson requested every member to send back a list of convenient dates by E-mail. Your mission is to help the chairperson, who is now dedicated to other issues of the contest, by writing a program that chooses the best date from the submitted lists. Your program should find the date convenient for the most members. If there is more than one such day, the earliest is the best.

Input
The input has multiple data sets, each starting with a line containing the number of committee members and the quorum of the meeting.

N Q
Here, N, meaning the size of the committee, and Q meaning the quorum, are positive integers. N is less than 50, and, of course, Q is less than or equal to N.

N lines follow, each describing convenient dates for a committee member in the following format.

M Date1 Date2 … DateM
Here, M means the number of convenient dates for the member, which is an integer greater than or equal to zero. The remaining items in the line are his/her dates of convenience, which are positive integers less than 100, that is, 1 means tomorrow, 2 means the day after tomorrow, and so on. They are in ascending order without any repetition and separated by a space character. Lines have neither leading nor trailing spaces.

A line containing two zeros indicates the end of the input.

Output
For each data set, print a single line containing the date number convenient for the largest number of committee members. If there is more than one such date, print the earliest. However, if no dates are convenient for more than or equal to the quorum number of members, print 0 instead.

Sample Input

3 2
2 1 4
0
3 3 4 8
3 2
4 1 5 8 9
3 2 5 9
5 2 4 5 7 9
3 3
2 1 4
3 2 5 9
2 2 4
3 3
2 1 2
3 1 2 9
2 2 4
0 0

Sample Output

4
5
0
2

Source
Japan 2003 Domestic

解题代码

#include <iostream>
#include <cstring>
using namespace std;

#define LEN 100
int flag[LEN] = {0};

int main()
{
    int N, Q, M, m;
    while((cin >> N >> Q) && (N || Q))
    {
        int nMax = -1;
        int index = 0;
        memset(flag, 0, sizeof(flag));

        while (N--)
        {
            cin >> M;
            while (M--)
            {
                cin >> m;
                flag[m]++;

                if (flag[m] > nMax || (flag[m] == nMax && m < index))
                {
                    nMax = flag[m];
                    index = m;
                }
            }
        }
        cout << (nMax >= Q ? index : 0) << endl;
    }
    return 0;
}

解题槽点

  • 一开始拿到这个题目一度认为题目描述有问题,原因是我把原题的这一句“M Date1 Date2 … DateM”中开头的M漏看了,结果根据输入推算输出的时候总会卡住,发现有部分例子不符合,上网查询题意时,发现没有人提到这样一点,难道只有我一个人犯了这个错误吗?后来还是写代码时发现缺少条件才从题目中找出了自己的问题,所以我决定将这个问题列举在此,为遇到此问题的小伙伴提个醒。

  • 这个问题还有一个需要注意的就是需要每组示例读取前,需要把标记数组清空,如果你想一次就AC,这个问题还是需要注意一下的,我是在自己调试的时候,看到输出结果不对才发现这个问题的。

提交结果


poj2028

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

AlbertS

常来“玩”啊~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值