poj1323解题报告

Game Prediction
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9689 Accepted: 4630

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4
源代码:
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n,m,i,t;
	int num,flag,c=1;
	int a[200];
	while (cin>>n>>m && n!=0 && m!=0)
	{
	   t=0;num=0;flag=0;
	   for (i=1;i<=m;i++)
	   {
	       cin>>a[i];
	   }
	   sort(a+1,a+1+m);
	   for (i=n*m;i>0;i--)
	   {
	       if (a[m]!=i)
			   num++;
		   else 
		   {
		       if (num)
				   num--;
			   else
				   t++; 
			   m--;
		   }
		   if (m<0) {break;}
	   }
	   cout<<"Case "<<c++<<": "<<t<<endl;
	}	
	return 0;
}
本题题意,模拟打牌的题目,给出n个人,每个人有m张牌数,牌的最大值为n*m,最小值为1,每次没人打出一张牌,最大的那个人胜出,给出你的所有的m张牌,你设计程序计算出你最多能赢多少场。
解题思路:简单的贪心算法,因为所有牌的值你都知道,所以首先判断你又多少张牌没有,从最大的开始判断,如果最大的你有了,你就肯定会获胜,如果最大有了,第二没有,3,4,5大的都有,说明你至少会赢2局,我的思路是,从最大的n*m开始判断你有没有,没有就用num来记录,当你有,t才++,最后输出t就行,一开始我把m--写在了else外面,死活不过,后来发现m--是必须判断到有相同的值才能自减,这个大家相同就容易多了,还是比较推荐大家试试的。
POJ1753题目为"Flip Game",题目给出了一个4x4的棋盘,每个格子有黑色或白色,每次翻转一个格子会同时翻转它上下左右四个格子的颜色,目标是把整个棋盘都变为同一种颜色,求把棋盘变成同种颜色的最小步数。 解题思路: 一般关于棋盘变色的题目,可以考虑使用搜索来解决。对于POJ1753题目,可以使用广度优先搜索(BFS)来解决。 首先,对于每个格子,定义一个状态,0表示当前格子是白色,1表示当前格子是黑色。 然后,我们可以把棋盘抽象成一个长度为16的二进制数,将所有格子的状态按照从左往右,从上往下的顺序排列,就可以用一个16位的二进制数表示整个棋盘的状态。例如,一个棋盘状态为: 0101 1010 0101 1010 则按照从左往右,从上往下的顺序把所有格子的状态连接起来,即可得到该棋盘的状态为"0101101001011010"。 接着,我们可以使用队列来实现广度优先搜索。首先将初始状态加入队列中,然后对于队列中的每一个状态,我们都尝试将棋盘上的每个格子翻转一次,生成一个新状态,将新状态加入队列中。对于每一个新状态,我们也需要记录它是从哪个状态翻转得到的,以便在得到最终状态时能够输出路径。 在搜索过程中,我们需要维护每个状态离初始状态的步数,即将该状态转换为最终状态需要的最小步数。如果我们找到了最终状态,就可以输出答案,即最小步数。 代码实现:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值