poj1961解题报告

Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 13616 Accepted: 6417

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
源代码:
#include<iostream>
#include<cstring>
using namespace std;
int next[1000010];
char ch[1000010];
int len;
void getnext()
{
    int i,j;
	i=0;
	j=-1;
	next[0]=-1;
	while (i!=len)
	{
	    if (j==-1 || ch[i]==ch[j])
			next[++i]=++j;
		else 
			j=next[j];
	}
}
int main()
{
    int i,length,t=1;
	while (cin>>len && len!=0)
	{
	    scanf("%s",ch);
		getnext();
		cout<<"Test case #"<<t<<endl;
		t++;
        for (i=1;i<=len;++i)
		{
		    length=i-next[i];
			if (i!=length && i%length==0)
				cout<<i<<" "<<i/length<<endl;
		}
		cout<<endl;
	}
	return 0;
}
本题题意:本题跟2406差不多,就是要再进行一次遍历,寻找出所有能够循环的次数,给你一个字符串,你要将里面可以循环的区间都求出来,但是区间的开头必须是从0开始的,遍历一遍,找出从0开始可以循环的全部符合要求的区间,再把区间里面循环的次数给输出出来,同样也是用了kmp算法的求next数组,两道题几乎相似,推荐大家做kmp算法类型的题目时候1961和2406一起做,这样更容易巩固。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值