HDU .2639.Bone Collector II 01背包

Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1

 

 

Sample Output

 

12 2 0

 

该题问的是01背包所有能装的方案中总重量第K大的重量是多少。在原来的dp[i]上多加一维K,dp[i][k]表示前i个物品的选择情况在背包中的第K大重量。那么每个状态都有从i-1的转移,选和不选每次是2*K只需要从这之中选出K个赋给1~k 从大到小这里的赋值有点小技巧,首先在每次的最后用-1封尾,之后用两个变量分别指向选和不选两个数组的起点(起点即K==1的时候的决策之后的两种重量)所以这些2*k个转移肯定是"相对有序"的转移的时候只需要从目前两个指针所指向的值取较大值。

在这之后我也尝试过用数组存起来最后sort一下时间差了好多.

#include <iostream>
#include <cstdio>
#include <set>
#include <map>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
int dp[50000][35],a[2][35];
int val[50000],we[50000];
bool cmp(int a,int b){
    return a>b;
}
int main(){
    int n,m,k,t;
    cin>>t;
    while(t--)
    {
        scanf("%d%d%d",&n ,&m ,&k);
        for(int i=1;i<=n;i++){
            scanf("%d",&val[i]);
        }
        for(int i=1;i<=n;i++){
            scanf("%d",&we[i]);
        }
        memset( dp,0,sizeof(dp) );
        for(int i=1;i<=n;i++){
            for(int j=m;j>=we[i];j--){

                for(int l=1;l<=k;l++){
                    a[0][l]=dp[j][l];
                    a[1][l]=dp[j-we[i]][l]+val[i];
                }
                a[0][k+1]=-1,a[1][k+1]=-1;
                int l=1,r=1,ans=1;
                while(ans<=k&&(l<k+1||r<k+1)){
                    if(a[0][l]>a[1][r])
                        dp[j][ans]=a[0][l],l++;
                    else
                        dp[j][ans]=a[1][r],r++;
                    if(dp[j][ans]!=dp[j][ans-1])
                        ans++;
                }
            }

        }
        cout<<dp[m][k]<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值