Best Cow Fences

POJ - 2018
这个题感受很多是个二分好题 用到了很好的技巧。
题意给你n个牛的自身价值,让你找出连续的且数量大于等于F的一段区间,使这段区间内的牛的平均价值最大。将其转化为二分很不好想 枚举平均值然后计算差值的前缀和与0比较省去不少麻烦 (还是见得少)

Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.
FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.
Calculate the fence placement that maximizes the average, given the constraint.
Input
*Line 1: Two space-separated integers, N and F.
*Lines 2…N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.
Output
Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000ncows/nfields.
Sample Input
10 6
6
4
2
10
3
8
5
9
4
1
Sample Output
6500

#include <iostream>
#include <cmath>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long ll;
double a[100009],dp[100009],b[100009],mid;
int inf=1e9;
int main()
{
    int k,u,m,c,n;
    while(cin>>n>>c)
    {
        double l=0,r=-1;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            l=min(l,a[i]);
            r=max(r,a[i]);
        }
        dp[0]=0;
        while(r-l>1e-5)
        {
            mid=(l+r)/2.0;
            for(int i=1;i<=n;i++)
            {
                dp[i]=dp[i-1]+a[i]-mid;
            }
            double minn=1e10,maxx=-1e10;
            for(int i=c;i<=n;i++)
            {
                minn=min(minn,dp[i-c]);
                maxx=max(maxx,dp[i]-minn);//这里节省了不少的时间挺巧秒的。
            }
            if(maxx>=0)
                l=mid;
            else
                r=mid;
        }
        cout<<(int)(r*1000)<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值