连接(应该可以这么说吧)优先队列——POJ 1442

对应POJ题目:点击打开链接


Black Box
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 
      (elements are arranged by non-descending)   

1 ADD(3)      0 3 
2 GET         1 3                                    3 
3 ADD(1)      1 1, 3 
4 GET         2 1, 3                                 3 
5 ADD(-4)     2 -4, 1, 3 
6 ADD(2)      2 -4, 1, 2, 3 
7 ADD(8)      2 -4, 1, 2, 3, 8 
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8 
9 GET         3 -1000, -4, 1, 2, 3, 8                1 
10 GET        4 -1000, -4, 1, 2, 3, 8                2 
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2


题意:给定M个数,每次可以插入序列一个数;再给N个数,表示在插入第几个数时输出一个数,第一次输出序列中最小的,第二次输出序列中第二小的……以此类推,直到输出N个数。


分析:因为输出时是按照先输出最小的,再输出第二小这样的方式输出的,相当于依次输出一个有序序列中的值。但因为这个序列不是固定不变的,而是不断的在更新,所以用数组是无法实现的。我们可以用优先队列来做。

定义两个优先队列,一个用来存储前k小的数,大数在前,小数在后;另一个优先队列第k+1小到最大的数,小数在前,大数在后。每次拿到一个数,先判断第一个优先队列中的数满不满k个,如果不满k个,则直接把这个数压入到第一个队列;如果满k个,判断这个数和第一个优先队列中的第一个数的大小:如果比第一个数大,就压入第二个优先队列;如果比第一个数小,就把第一个优先队列的队首元素弹出压入第二个队列,把这个新数压入第一个优先队列。

别人的题解,颇具启发性~

两个优先队列即是这样:




#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=30000+10;
using namespace std;
int a[MAXN];
int b[MAXN];

int main()
{
	freopen("in.txt","r",stdin);
	int n,m;
	while(scanf("%d%d", &n,&m)==2)
	{
		priority_queue<int>q1;//栈顶元素最大
		priority_queue<int,vector<int>,greater<int> >q2;//栈顶元素最小
		int i,j;
		for(i=1; i<=n; i++){
			scanf("%d", &a[i]);
		}
		for(i=1; i<=m; i++){
			scanf("%d", &b[i]);
		}
		j=1;
		int k=1;//要输出第k小的数
		for(i=1; i<=n; i++){//把数放入栈
			if(q1.size()<k) q1.push(a[i]);//q1如果没有达到k个数,把数放入q1
			else{    //否则,用a[i]和q1队首元素比较,小的在q1,大的在q2
				int t=q1.top();
				if(a[i]>=t) q2.push(a[i]);
				else{
					q2.push(t);
					q1.pop();
					q1.push(a[i]);
				}
			}
			while(i==b[j])//在放入第b[j]个数后就要输出第k小的数,即q1队首元素
			{
				printf("%d\n",q1.top());
				k++; j++;
				if(!q2.empty()){  //q1长度+1,从q2取最小元素放入q1,继续判断是不是第b[j]次放入数字
					q1.push(q2.top());
					q2.pop();
				}
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值