对应POJ题目:点击打开链接
Time Limit: 5000MS | Memory Limit: 131072KB | 64bit IO Format: %I64d & %I64u |
Description
N children are sitting in a circle to play a game.
The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.
The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?
Input
Output
Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.
Sample Input
4 2 Tom 2 Jack 4 Mary -1 Sam 1
Sample Output
Sam 3
Source
题意:有N个人,从第K个人X开始出列,下一个出列的人根据X手上的牌的数字,正数就顺时针,否则逆时针,问到谁出列时获得的糖果最多(糖果数即是K的因子数),即是第N的最大反素数出列时能得到最多的糖果;
线段树维护的是该区间还有多少人没有出列;
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
const int MAXN=500000+10;
using namespace std;
int c[MAXN];
const int ap[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,554400};
const int f[] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,216};
int n,k;
struct People
{
char name[15];
int card;
}p[MAXN];
int tree[MAXN*4];
void buildtree(int left, int right, int pos)
{
if(left==right){
tree[pos]=1;
return;
}
int mid=(left+right)>>1;
buildtree(left, mid, pos<<1);
buildtree(mid+1, right, pos<<1|1);
tree[pos]=tree[pos<<1]+tree[pos<<1|1];
}
int updata(int left, int right, int pos, int x)
{
tree[pos]--;
if(left==right) return left;
int mid=(left+right)>>1;
if(tree[pos<<1]>=x) updata(left, mid, pos<<1, x);
else updata(mid+1, right, pos<<1|1, x-tree[pos<<1]);
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d%d", &n,&k)==2)
{
memset(c,0,sizeof(c));
int cnt=0;
while(ap[cnt]<=n) cnt++;
cnt--;
int most=ap[cnt];
int i,j;
for(i=1; i<=n; i++){
scanf("%s%d", p[i].name, &p[i].card);
}
buildtree(1,n,1);
/*for(i=1; i<=30; i++){
cout<<"tree["<<i<<"].val="<<tree[i]<<endl;
}*/
int pos=0;
p[pos].card=0;
int len=n;
for(i=1; i<=most; i++){
if(p[pos].card>0) k=(k+p[pos].card-2)%len+1;
else k=((k+p[pos].card-1)%len+len)%len+1;
pos=updata(1, n, 1, k);
//cout<<k<<endl;
//cout<<pos<<endl<<endl;
len--;
}
printf("%s %d\n", p[pos].name, f[cnt]);
}
return 0;
}