二分图最小路径覆盖——POJ 3020

对应POJ题目:点击打开链接


 Antenna Placement
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5



题意:‘*’表示城市,“o”表示空地,一个天线只能把上下左右2个相邻的城市圈起来,问至少需要多少个天线才能把所有的城市圈起来。

例1的前2行使之变成

0 0 0 1 2 0 0 0 0

3 4 0 0 6 0 0 0 7

把非0的上下左右相邻的城市连起来,即G[1][2] = 1,G[2][1] = 1, G[3][4] = 1等等;在求最大匹配时,由于是无向边,故要Max/2。于是结果就是

城市数 - 最大匹配/2。


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
#define ms(x,y) memset(x,y,sizeof(x))
const int MAXN=1000+10;
const int INF=1<<30;
using namespace std;
int G[50][20];
int net[410][410];
int link[410];
int vis[410];
int cnt;

int dfs(int u)
{
	for(int v=1; v<=cnt; v++){
		if(!vis[v] && net[u][v]){
			vis[v] = 1;
			if(link[v] == -1 || dfs(link[v])){
				link[v] = u;
				return 1;
			}
		}
	}
	return 0;
}

int MaxMatch()
{
	int res = 0;
	ms(link, -1);
	for(int i=1; i<=cnt; i++){
		ms(vis, 0);
		if(dfs(i)) res++;
	}
	return res;
}

int main()
{
	//freopen("in.txt","r",stdin);
	int T;
	scanf("%d", &T);
	while(T--)
	{
		ms(net, 0);
		cnt = 0;
		int r,c;
		scanf("%d%d", &r,&c);
		for(int i=1; i<=r; i++){
			char str[20];
			scanf("%s", str);
			for(int j=1; j<=c; j++){
				if(str[j-1] == '*') G[i][j] = ++cnt;
				else G[i][j] = 0;
			}
		}
		for(int i=1; i<=r; i++){
			for(int j=1; j<=c; j++){
				int u = G[i][j];
				int v1 = G[i-1][j];
				int v2 = G[i+1][j];
				int v3 = G[i][j-1];
				int v4 = G[i][j+1];
				if(v1) net[u][v1] = 1;
				if(v2) net[u][v2] = 1;
				if(v3) net[u][v3] = 1;
				if(v4) net[u][v4] = 1;
			}
		}
		int ans = cnt - MaxMatch()/2;
		printf("%d\n", ans);
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值