【HDU】2767 Proving Equivalences 强连通缩点

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2889    Accepted Submission(s): 1087


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
  
  
2 4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
 

Source


传送门:【HDU】2767 Proving Equivalences


题目大意:问你至少添加多少边能使得图强连通。


题目分析:强连通缩点,统计入度为0的分量个数a和出度为0的分量个数b。答案ans = max(a , b)。


代码如下:


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std ;

#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )

const int MAXN = 20005 ;
const int MAXE = 50005 ;

struct Edge {
    int v , n ;
    Edge ( int v = 0 , int n = 0 ) : v ( v ) , n ( n ) {}
} ;

struct SCC {
    Edge edge[MAXE] ;
    int adj[MAXN] , cntE ;
    int Dfn[MAXN] , Low[MAXN] ;
    int dfs_clock , scc_cnt ;
    int S[MAXN] , top ;
    int scc[MAXN] ;
    bool ins[MAXN] ;
    
    void init () {
        top = cntE = 0 ;
        scc_cnt = 0 ;
        dfs_clock = 0 ;
        CLEAR ( Dfn , 0 ) ;
        CLEAR ( ins , 0 ) ;
        CLEAR ( adj , -1 ) ;
    }
    
    void addedge ( int u , int v ) {
        edge[cntE] = Edge ( v , adj[u] ) ;
        adj[u] = cntE ++ ;
    }
    
    void Tarjan ( int u ) {
        Dfn[u] = Low[u] = ++ dfs_clock ;
        ins[u] = true ;
        S[top ++] = u ;
        for ( int i = adj[u] ; ~i ; i = edge[i].n ) {
            int v = edge[i].v ;
            if ( !Dfn[v] ) {
                Tarjan ( v ) ;
                Low[u] = min ( Low[u] , Low[v] ) ;
            }
            else if ( ins[v] )
                Low[u] = min ( Low[u] , Dfn[v] ) ;
        }
        if ( Dfn[u] == Low[u] ) {
            ++ scc_cnt ;
            while ( 1 ) {
                int v = S[-- top] ;
                scc[v] = scc_cnt ;
                ins[v] = 0 ;
                if ( v == u )
                    break ;
            }
        }
    }
    
    void find_SCC ( int n ) {
        REPF ( i , 1 , n )
            if( !Dfn[i] )
                Tarjan ( i ) ;
    }
} ;

SCC C ;
int in[MAXN] ;
int ou[MAXN] ;

void work () {
    int n , m ;
    int u , v ;
    scanf ( "%d%d" , &n , &m ) ;
    C.init () ;
    while ( m -- ) {
        scanf ( "%d%d" , &u , &v ) ;
        C.addedge ( u , v ) ;
    }
    C.find_SCC ( n ) ;
    if ( C.scc_cnt == 1 ) {
        printf ( "0\n" ) ;
        return ;
    }
    CLEAR ( in , 0 ) ;
    CLEAR ( ou , 0 ) ;
    REPF ( u , 1 , n )
        for ( int i = C.adj[u] ; ~i ; i = C.edge[i].n ) {
            int v = C.edge[i].v ;
            if ( C.scc[u] != C.scc[v] )
                ++ ou[C.scc[u]] , ++ in[C.scc[v]] ;
        }
    int deg_in = 0 , deg_ou = 0 ;
    REPF ( i , 1 , C.scc_cnt ) {
        if ( !in[i] )
            ++ deg_in ;
        if ( !ou[i] )
            ++ deg_ou ;
    }
    printf ( "%d\n" , max ( deg_in , deg_ou ) ) ;
}
    

int main () {
    int T ;
    scanf ( "%d" , &T ) ;
    while ( T -- )
        work () ;
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值