HDU2767-强连通

Proving Equivalences
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9532 Accepted Submission(s): 3362

Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies ©, that © implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to ©, and that © is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output
Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

题意:命题a证明b,b证明c,c证明d,d证明a,说明bc能证明a(传递的意思),
现在有n个命题,已知m个证明,问我还需要多少证明可以在n个命题中两两证明。
思路:大概就是强连通,现在问的是怎样加边可以把这个图变成一个强连通。我们知道一个强连通图的出度和入度是相同的,所以我们只需要算出所有的入度和出度输出最大就行。首先我们先用tarjan缩点,把一些强连通集合变成一个新的点,然后找出新的点的出度和入度,输出最大就行了。
AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxm=50000+50;
const int maxn=20000+20;
const int INF=0x7f7f7f7f;
struct Node
{
	int next,end;
}map[maxm];
int head[maxn],pre[maxn],dfn[maxn],stack[maxn];
int arr[maxn],in[maxn],out[maxn];
int n,m,sum;
int top,index,ans;
bool vis[maxn];
void Init()
{
	sum=0;
	memset(head,-1,sizeof(head));
	memset(pre,0,sizeof(pre));
	memset(dfn,0,sizeof(dfn));
	memset(stack,0,sizeof(stack));
	memset(arr,0,sizeof(arr));
	memset(in,0,sizeof(in));
	memset(out,0,sizeof(out));
	return ;
}
void addedge(int start,int end)
{
	map[sum].end=end;
	map[sum].next=head[start];
	head[start]=sum++;
	return ;
}
void tarjan(int start)
{
	pre[start]=dfn[start]=++index;
	stack[++top]=start;
	vis[start]=true;
	for (int i=head[start];i!=-1;i=map[i].next)
		{
			int end=map[i].end;
			if (dfn[end]==0)
				{
					tarjan(end);
					pre[start]=min(pre[start],pre[end]);
				}
			else if (vis[end]==true) pre[start]=min(pre[start],dfn[end]);
		}
	if (pre[start]==dfn[start])
		{
			ans++;
			int j=0;
			while (j!=start)
				{
					j=stack[top--];
					arr[j]=ans;			//合成一个点
					vis[j]=false;
				}
			arr[j]=ans;vis[j]=false;
		}
	return ;
}
int solve()
{
	ans=top=index=0;
	memset(vis,false,sizeof(vis));
	for (int i=1;i<=n;i++)
		if (dfn[i]==0) tarjan(i);
	if (ans==1) return 0;
	for (int i=1;i<=n;i++)
		for (int j=head[i];j!=-1;j=map[j].next)
			{
				if (arr[i]==arr[map[j].end]) continue;
				in[arr[map[j].end]]++;		//如果不是一个强连通集合里面的,记录出度和入度
				out[arr[i]]++;
			}
	int sum1,sum2;
	sum1=sum2=0;
	for (int i=1;i<=ans;i++)
		{
			if (in[i]==0) sum1++;
			if (out[i]==0) sum2++;
		}
	return max(sum1,sum2);
}
int main()
{
	int t;
	int start,end;
	cin>>t;
	while (t--)
		{
			cin>>n>>m;
			Init();
			for (int i=1;i<=m;i++)
				{
					scanf("%d%d",&start,&end);
					addedge(start,end);
				}
			int ans=solve();
			cout<<ans<<endl;
		}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值