PKU 3249 Test for Job

Test for Job
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8706 Accepted: 1939

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers  n and  m(1 ≤  n ≤ 100000, 0 ≤  m ≤ 1000000) indicating the number of cities and roads. 
The next  n lines each contain a single integer. The  ith line describes the net profit of the city  iVi (0 ≤ | Vi| ≤ 20000) 
The next m lines each contain two integers  xy indicating that there is a road leads from city  x to city  y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint





题意:给定一个有向无环图,求以其中的一个入度为零的点为源点,出发到一个出度为0的点的最长路径。
解题思路:有向无环图单源点最短路径,首先采用链式前向星储存图,然后将图进行拓扑排序后,套用有向无环图单源点最短路径算法,时间复杂度为O(m)

#include <stdio.h>
#include <iostream>
#include <string.h>

using namespace std;

#define MIN -2002000000

struct Edg
{
    int from, to;
    int w;
    int next;
}edg[2000010];
int v[100010];
int vw[100010];
int indegree[100010];
int head[100010];
int queue[200000];
long long dis[100000], answer;

int main()
{
    int n, m, i, j;
    int f, t;
    int lq;
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        memset(edg, 0, sizeof(edg));
        memset(v, 0, sizeof(v));
        memset(vw, 0, sizeof(vw));
        memset(indegree, 0, sizeof(indegree));
        memset(head, 0, sizeof(head));
        memset(queue, 0, sizeof(queue));

        for(i=1; i<=n; i++)
            scanf("%d", &vw[i]);

        for(i=1; i<=m; i++)
        {
            scanf("%d%d", &f, &t);
            edg[i].from = f;
            edg[i].to = t;
            edg[i].next = head[f];
            head[f] = i;
            edg[i].w = vw[t];
            indegree[t]++;
        }
        for(i=1; i<=n; i++)
        {
            if(!indegree[i])
            {
                edg[++m].from = 0;
                edg[m].to = i;
                edg[m].next = head[0];
                head[0] = m;
                edg[m].w = vw[i];
                indegree[i]++;
            }
        }


        //拓扑排序;
        lq = 0;
        queue[lq++] = 0;
        for(i=0; i<lq; i++)
        {
            for(j=head[queue[i]];j!=0; j=edg[j].next)
            {
                indegree[edg[j].to]--;
                if(indegree[edg[j].to]==0)
                    queue[lq++] = edg[j].to;
            }
        }
       // for(i=0; i<lq; i++) printf("%d", queue[i]);cout<<endl;

        dis[0] = 0;
        answer = MIN;
        for(i=1; i<=n; i++) dis[i] = MIN;
        for(i=0;i<lq; i++)
        {
            if(head[queue[i]]==0&&answer<dis[queue[i]]) answer = dis[queue[i]];
            for(j=head[queue[i]]; j!=0; j = edg[j].next)
            {
                if(dis[edg[j].to]<dis[queue[i]]+edg[j].w)
                    dis[edg[j].to] = dis[queue[i]]+edg[j].w;
            }
        }

        printf("%lld\n", answer);
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值