How many Fibs?(JAVA)大数

Problem B: How many Fibs?

Recall the definition of the Fibonacci numbers:

f 1 := 1 
f 2 := 2 
f n :=  f n-1 +  f n-2     (n>=3)
Given two numbers  a  and  b , calculate how many Fibonacci numbers are in the range [ a , b ].

Input Specification

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10100. The numbers a and b are given with no superfluous leading zeros.

Output Specification

For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.

Sample Input

10 100
1234567890 9876543210
0 0

Sample Output

5
4

题目看完,显然是高精度,C肯定可以做,不过这里给出JAVA代码。


import java.math.*;  
import java.util.*;  
import java.io.*;   
public class Main{  
    public static void main(String[] args) {  
        Scanner cin = new Scanner(System.in); 
        BigInteger [] s=new BigInteger [50010];
        BigInteger n,m;
        BigInteger k=new BigInteger("0");
        s[2]=new BigInteger ("2");
        s[1]=new BigInteger ("1");
        for(int i=3;i<=50000;i++)
        {
        s[i]=s[i-1].add(s[i-2]);
        }
        while(cin.hasNextBigInteger()){  
        int sum=0;
        n=cin.nextBigInteger();
        m=cin.nextBigInteger();
        if(n.compareTo(k)==0&&m.compareTo(k)==0)
        break;
        for(int i=1;i<=50000;i++)
        {
        if((s[i].compareTo(n)>=0)&&(s[i].compareTo(m)<=0))
        sum++;
        }
        System.out.println(sum);  
        }  
    }  

}


唯一需要注意的是数组大小,开到10W会超时,1W会WA,大概估算开到5W就可以了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值