模拟时钟

该博客介绍了如何使用3*3字符表示的数字时钟来显示时间。给定当前时间的四个整数,需要将其转换为这种特殊形式的时钟表示,并提供示例输入和输出。
摘要由CSDN通过智能技术生成

1003: Time

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 113   Solved: 67
[ Submit][ Status][ Web Board] [ Edit] [ TestData]

Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases.

Each case contains 4 integers in a line, separated by space.

Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

HINT

The digits showed by the digital clock are as follows:

   _  _     _  _  _  _  _  _ 

 | _| _||_||_ |_   ||_||_|| |

 ||_  _|  | _||_|  ||_| _||_|

Source

辽宁省赛2010


模拟题:

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;

#pragma comment(linker, "/STACK:102400000,102400000")

typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;



const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
const int maxn = 1001;
int a[4];

string s1[maxn] = { " _ " , "   " , " _ " , " _ " , "   " , " _ " , " _ " , " _ " , " _ " , " _ " };
string s2[maxn] = { "| |" , "  |" , " _|" , " _|" , "|_|" , "|_ " , "|_ " , "  |" , "|_|" , "|_|" };
string s3[maxn] = { "|_|" , "  |" , "|_ " , " _|" , "  |" , " _|" , "|_|" , "  |" , "|_|" , " _|" };



int main()
{
    #ifdef xxz
    freopen("in.txt","r",stdin);
    #endif
    while(cin >> a[0] >>a[1] >> a[2] >> a[3])
    {

        for(int i = 0 ; i < 4 ; i ++)
        {
            cout << s1[a[i]];
        }
        cout << endl;

        for(int i = 0 ; i < 4 ; i ++)
        {
            cout << s2[a[i]];
        }
        cout << endl;

        for(int i = 0 ; i < 4 ; i ++)
        {
            cout << s3[a[i]];
        }
        cout << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值