HDU 1052 Tian Ji -- The Horse Racing (贪心)

26 篇文章 0 订阅

这是一道很经典的贪心题目~~~

  Tian Ji -- The Horse Racing

Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input

    
    
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output

  
  
200 0 0




题意:古老的田忌赛马,经典问题重现。田忌和齐威王赛马,两人有相同的马数,每匹马的速度不定,规定速度大的马一定能跑赢速度小的马(没有意外),田忌每赢一局可赢200元,输一局输200元,平局不输不赢。给各匹马的速度,求田忌最多能赢多少钱。


心得:神坑啊.......贪心方法想不对,一顿WA,WA到吐血...........太坑了,很经典的问题,以前就做过田忌赛马,但是是简化版的,这个确实不好弄。后来听了队友的想法,才恍然大悟啊,贪心少了一步....................


分析:经典贪心,总体来讲三个步骤:

           1.若田忌最快的马比齐威王最快的马快,直接比;                

           2.若田忌最快的马比齐威王最快的马慢,用田忌最慢的马跟齐威王最快的马比;              //  贪心第一步

           3.若田忌最快的马与齐威王最快的马一样快:

               3.1.若田忌最慢的马比齐威王最慢的马快,两者直接比;                                                   //  贪心第二步

               3.2.若田忌最慢的马比齐威王最慢的马慢,用田忌最慢的马跟齐威王最快的马比;

               3.3.若田忌最慢的马与齐威王最慢的马一样快,用田忌最慢的马跟齐威王最快的马比。





AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define INF 0x7fffffff
using namespace std;
const int maxn = 1000 + 10;
int t[maxn],k[maxn];

int main()
{
    int n,ans1,ans2,ans3;
    while(scanf("%d",&n)!=EOF && n)
    {
        ans1 = ans2 = ans3 = 0;
        for(int i = 0; i < n; i++)
            scanf("%d",&t[i]);
        for(int i = 0; i < n; i++)
            scanf("%d",&k[i]);
        sort(t,t+n);         //先将两人的马排序
        sort(k,k+n);
        int i = 0,j = 0, ij = n-1,ji = n-1,ki = 0;       //ki是齐威王已经用掉的马的数量
        while(1)
        {
            if(ki == n)  break;        //king的马全比完了
            if(t[ij] > k[ji]) { ij--; ji--; ki++; ans1++; }         // 两快比
            else if(t[ij] < k[ji]) { i++; ji--; ki++; ans2++; }     // 田慢王快比
            else if(t[ij] == k[ji])                                  
            {
                if(t[i] > k[j])  { i++; j++; ki++; ans1++; }        // 两慢比
                else if(t[i] <= k[j])                               
                {
                    if(t[i] < k[ji])  { i++; ji--; ki++;  ans2++; }  // 田慢王快比 
                    else  { i++; ji--; ki++; }                       // 田慢王快等,则不比
                }
            }
        }
        printf("%d\n",(ans1-ans2)*200);
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值