POJ 3723 Conscription (最大权森林 + Kruskal算法)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8317 Accepted: 2887

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source





题意:现需要征募女兵N人,男兵M人。每征募一个人需要花费10000美元,但是如果已经征募的人中有一些关系亲密的人,那么可以少花一些钱。给出若干的男女之间的1~9999之间的亲密度关系,征募某个人的费用就是 10000 - (已经征募的人中和自己的亲密度的最大值)。要求通过适当的征募顺序使得征募所有人所需要费用的最小。


解析:先设想一下这样的无向图:在征募某人a的时候,如果使用了a和b之间的关系,那么就连一条边a到b的边。假设这个图中存在圈,那么无论以什么顺序征募这个圈上的所有人,都会产生矛盾。因此可以知道这个图是一片森林。反之,如果给了一片森林那么就可以使用对应的关系群定征募的顺序。因此,把人看作顶点,关系看作边,这个问题就可以转化为求解无向图中的最大权森林问题。最大权森林问题可以通过把所有边权取反之后用最小生成树的算法求解。




AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b)  a+(b-a)/2
#define MAX_E  50000 + 10
#define MAX_N  10000 + 10


int pa[2*MAX_N], rank[2*MAX_N];       //并查集
void init_union_find(int V){
    for(int i=0; i<V; i++){
        pa[i] = i;
        rank[i] = 0;
    }
}

int find(int x){            
    return x == pa[x] ? x : pa[x] = find(pa[x]);
}

void unite(int x, int y){
    x = find(x), y = find(y);
    if(x != y){
        if(rank[x] < rank[y]) pa[x] = y;
        else{
            pa[y] = x;
            if(rank[x] == rank[y]) rank[x] ++;
        }
    }
}

bool same(int x, int y){
    return find(x) == find(y);
}

struct edge{ int u, v, cost; };

bool cmp(edge a, edge b){
    return a.cost < b.cost;
}

edge es[MAX_E];
int V, E;

long long kruskal(){              //kruskal算法  
    sort(es, es+E, cmp);
    init_union_find(V);
    long long ans = 0;
    for(int i=0; i<E; i++){
        edge e = es[i];
        if(!same(e.u, e.v)){
            unite(e.u, e.v);
            ans += e.cost;
        }
    }
    return ans;
}

int N, M, R;

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int t, x, y, d;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d%d", &N, &M, &R);
        V = N + M;
        E = R;
        for(int i=0; i<R; i++){
            scanf("%d%d%d", &x, &y, &d);
            es[i].u = x;                     //这三句赋值,也可以换成es[i] = (edge){ x, y+N, -d };不过只能在用G++交才可以过,C++会CE
            es[i].v = N + y;
            es[i].cost = -d;
        }
        printf("%lld\n", 10000 * (N + M) + kruskal());
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值