BestCoder Round #32

1001  PM2.5


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in asending order. Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them according to the input order.
 
Input
  
  
Multi test cases (about 100  ), every case contains an integer n  which represents there are n  cities to be sorted in the first line. Cities are numbered through 0 to n1  . In the next n  lines each line contains two integers which represent the first and second measurement of content of PM2.5 The ith line describes the information of city i1  Please process to the end of file. [Technical Specification] all integers are in the range [1,100] 
 
Output
  
  
For each case, output the cities’ id in one line according to their order.
 
Sample Input
  
  
2 100 1 1 2 3 100 50 3 4 1 2
 
Sample Output
  
  
0 1 0 2 1



题意:按要求排序。

解析:对于输入的每一行一两个整数作差,按照差值从大到小排序,如果差值一样,按照后面的整数从小到大排序,如果还是一样按照ID从小到大排序。



AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b)  a+(b-a)/2
const int maxn = 1000 + 10;

#pragma comment(linker, "/STACK:1024000000,1024000000")       //手动扩栈

typedef struct pm{
    int x, y;
    int id;
};
pm node[1002];

int cmp(pm a, pm b){                 //关键是比较函数
    if(a.x - a.y == b.x - b.y && a.y == b.y) return a.id < b.id;
    if(a.x - a.y == b.x - b.y) return a.y < b.y;
    return a.x - a.y > b.x - b.y;
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int n;
    while(scanf("%d", &n)!=EOF){
        for(int i=0; i<n; i++){
            scanf("%d%d", &node[i].x, &node[i].y);
            node[i].id = i;
        }
        sort(node, node+n, cmp);
        for(int i=0; i<n; i++) printf("%d%c", node[i].id, i < n-1 ? ' ' : '\n');
    }
    return 0;
}



待续。。。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值