ACdream 1224 Robbers (贪心)

Robbers

Special Judge Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)
Problem Description

      N robbers have robbed the bank. As the result of their crime they chanced to get M golden coins. Before the robbery the band has made an agreement that after the robbery i-th gangster would get Xi/Y of all money gained. However, it turned out that M may be not divisible by Y.

The problem which now should be solved by robbers is what to do with the coins. They would like to share them fairly. Let us suppose that i-th robber would get Ki coins. In this case unfairness of this fact is |Xi/Y - Ki/M|. The total unfairness is the sum of all particular unfairnesses. Your task as the leader of the gang is to spread money among robbers in such a way that the total unfairness is minimized.

Input
      The first line of the input file contains numbers N, M and Y (1 ≤ N ≤ 1000, 1 ≤ M, Y ≤ 10000). N integer numbers follow - X i (1 ≤ X i ≤ 10000, sum of all X i is Y).
Output
      Output N integer numbers - K i (sum of all K i must be M), so that the total unfairness is minimal.
Sample Input
3 10 4
1 1 2
Sample Output
2 3 5
Source
Andrew Stankevich Contest 2
Manager

解析:先对每个人都按比例向下取整得到k[i],之后再将剩下的金币每次都分给当前“不公平值”最大的那个人,这样就会让他的“不公平值”减小,直到所有的金币分配完为止。




AC代码:

#include <bits/stdc++.h>
using namespace std;

int k[1002], x[1002];
bool flag[1002];

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    //    freopen("out.txt", "w", stdout);
    #endif // sxk

    int n, m, y, sum;
    while(scanf("%d%d%d", &n, &m, &y)!=EOF){
        sum = 0;
        for(int i=0; i<n; i++){
            scanf("%d", &x[i]);
            k[i] = m * x[i] / y;
            if(m * x[i] % y == 0) flag[i] = true;
            sum += k[i];
        }

        int tx = m - sum;
        while(tx--){
            double t = 0;
            int j = 0;
            for(int i=0; i<n; i++){
                if(flag[i]) continue;
                double foo = (double)x[i]/y - (double)k[i]/m;
                if(t < foo){
                    t = foo;
                    j = i;
                }
            }
            k[j] ++;
        }
        for(int i=0; i<n-1; i++) printf("%d ", k[i]);
        printf("%d\n", k[n-1]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值