XTU 1207 Welcome to XTCPC (模拟)

Welcome to XTCPC

Accepted : 190 Submit : 381
Time Limit : 1000 MS Memory Limit : 65536 KB

Problem Description

Welcome to XTCPC!XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not.Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases.For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input
3
XTCPC
CCC
XXXXTTTTCCCCPPPCCC


Sample Output
Case 1: Yes
Case 2: No
Case 3: Yes



Source

XTU OnlineJudge




解析:查看数组中是否存在有序的“XTCPC“即可。




AC代码:

#include <bits/stdc++.h>
using namespace std;

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int t;
    int f1, f2, f3, f4, f5;
    string s;
    scanf("%d", &t);
    for(int i=1; i<=t; i++){
        f1 = f2 = f3 = f4 = f5 = 0;
        cin>>s;
        int len = s.size();
        for(int j=0; j<len; j++){
            if(f1){
                if(f2){
                    if(f3){
                        if(f4){
                            if(s[j] == 'C'){
                                f5 = 1;
                                break;
                            }
                        }
                        else if(s[j] == 'P') f4 = 1;
                    }
                    else if(s[j] == 'C') f3 = 1;
                }
                else if(s[j] == 'T') f2 = 1;
            }
            else if(s[j] == 'X') f1 = 1;
        }
        printf("Case %d: %s\n", i, f5 ? "Yes" : "No");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值