Fix the computers ——(并查集) 结题报告

题目:

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL

SUCCESS

题目大意:

有n台电脑需要修理,电脑之间的最远沟通距离为m,输入O代表修理电脑,即O   1,修理编号为一的电 脑,输入S代表测试两台电脑之间的距离,即S    1    3,判断编号为1  3 的电脑能否通讯。

解题思想:

此题可运用并查集思想,只要修理一台电脑就让可以与此台电脑在m距离的范围内的电脑建立联系,

能够连同的电脑拥有共同的首领,判断条件为如果首领相同就可以沟通。

代码如下:

#include<stdio.h>

int a[1005][2],b[1005]={0},e[1005];//b为标记是否修理了,e为首领,a为电脑坐标
int n,m;
int find(int x)//找首领
{
    if(e[x]!=x)
        return find(e[x]);
    else
        return x;
}
void link(int x,int y)//建立联系
{
    int xx,yy;
   xx=find(x);
   yy=find(y);
   if(xx!=yy)
    e[xx]=yy;
}
main()
{
    int p,q,t,i,p1,q1;
    char c;
    scanf("%d%d",&n,&m);//n台电脑,m为两台电脑可以交流的最大长度
    for(i=1;i<=n;i++)
    {
        scanf("%d%d",&a[i][0],&a[i][1]);

    }
    getchar();
    for(i=1;i<=n;i++)
        e[i]=i;
    while(scanf("%c",&c)!=EOF)
    {

        if(c=='O')
        {
            scanf("%d",&p);
            b[p]=1;
            for(i=1;i<=n;i++)
            {
                if(b[i]==1)
                {
                    t=(a[p][0]-a[i][0])*(a[p][0]-a[i][0])+(a[p][1]-a[i][1])*(a[p][1]-a[i][1]);
                    if(t<=m*m)
                    {
                        link(p,i);
                    }
                }
            }
        }
        if(c=='S')
        {
            scanf("%d%d",&p,&q);
            p1=find(p);
            q1=find(q);
            if(p1==q1)
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
      
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值